toolbar greyed out

Hi folks,

Can anyone help me? I’m desperate and in a little bit of a panic. :frowning:

What’s wrong - Scrivener’s toolbar has suddenly become greyed out. Clicking in the binder, or even in the document area has no effect. I have closed Scriv and reopened it, to find the same problem.

What I was doing at the time - I’ve been working with it all day, copying tracts of text and pasting into Word, just switching between the two programs. I selected several consecutive scrivenings in the binder by selecting the first, holding [shift] then selecting the second. Then I tried to use the ‘edit scrivenings’ button, but it is greyed out. Just a few moments ago, it was working fine, with a different part of the document. ALL the toolbar buttons are greyed out now.

I’m not great with keyboard shortcuts, but it seems they are still working - although I cannot select the Binder button, or the Annotations button, I can use keyboard shortcuts to hide/show the binder, and start/stop annotated text.

Trouble is, I don’t have time to learn all the shortcuts I need right now, as the project is my thesis, due in on Friday. And I’m still several thousand words away from a complete second draft. :cry: I know this will turn out to be user error in the end and my panic isn’t helping, but is anyone out there that could help me today?

This post was me saying not to worry, I’d fixed it with a reboot. Turns out I didn’t fix it at all (see below).

Sarah

erm, hi folks, again.

It’s happened again. Here’s what seems to bring it on:

  • I select a few consecutive scrivenings and click ‘Edit Scrivenings’ button. All good so far.
  • I then right-click on the binder items I have selected (and that are highlighted), and change the progress indicator. The colour of the scrivening changes in the binder (and info panel) just fine, but instantly the toolbar becomes greyed out. But this time, the buttons for Keywords, Info, Full Screen and Binder remain usable. Buttons not working are: New, Delete, Edit Scrivenings, Open in External Editor, Import Web Page, Highlight, Corkboard, Outliner, Typewriter mode and Speech.

Selecting other scrivenings or moving focus between the binder and an open document and the info pane make no difference, the toolbar remains.

Anyone got any thoughts on this?
Sarah

Hi,

Sorry you’re having difficulties. What do you mean by “change the progress indicator”? What progress indicator do you mean?

Could you please open up the Console application (from the ~/Applications/Utilities folder) and see if any errors are getting reported there when this happens?

Thanks,
Keith

I think she is right-clicking on the items and setting their label to a different colour—and has icon tinting turned on. The described behaviour would match that action.

I cannot replicate the conditions though. When I have Edit Scrivenings on, and change the label for the group of documents, the toolbar remains functional.

That’s what I assumed too, and it worked fine when I tried it which is why I figured I’d ask for clarification just in case it is something else causing the problems… Odd.

P.S. Psst! StudentSarah! If you have auto-notification of topics turned on, please don’t have auto-reply to e-mails turned on - the auto-notification ends up with me getting an auto-reply. :slight_smile:

oops! Sorry Keith, I forgot about that :blush: have now switched it off.

Yes, Amber has it - I was using the context menu to change ‘Progress’ for multiple scrivenings - it seems to be what triggers the problem. I just did it again withe console running, and it produced this:

[code]11/04/2010 10:42:43 Scrivener[1662] Custom ColorPicker class with name .com.freeverselib could not be loaded.

11/04/2010 10:42:43 Scrivener[1662] Custom ColorPicker class with name .com.freeverselib could not be loaded.

11/04/2010 10:48:25 Scrivener[1662] *** -[NSCFArray initWithObjects:count:]: attempt to insert nil object at objects[0] [/code]

Does this help?
Sarah

EDIT: I’m using 1.54 version of Scriv, and Word 2008 for Mac, in case that information has any bearing!

Yep, an exception is getting thrown for some reason which will then mess up the rest of the running of the app. Can you zip up and send me the project?
Thanks,
Keith

Winging it’s way to you now. I still find it a little surreal that someone can post a moan on a forum on a Saturday afternoon, and have the attention of the software developer just like that. It really is quite awseome, thanks’ Keith :smiley:

Sarah