Trouble assigning shortcut to character style

I’m a heavy user of paragraph styles and shortcuts. But when I try to assign a keyboard shortcut to a character style, I can’t get it to work. The style works if I apply it from the pop-up window. Suggestions?

I’m on Mac OS only. I want to be able to highlight just a few words inside a paragraph, usually because there’s something that needs to be fixed and I’m adding an inline note.

Thanks,

Steve

As an aside, just in case you haven’t come across it yet, there is a dedicated feature for inline annotations with its own shortcut in the Insert menu. It has a distinct look, and individual notes can be colour coded. That said, styles work for this as well (with a little setup in the compiler, “notation” styles can be set to delete themselves instead of printing text) and can be good if you need more than just colour coding to set multiple note streams apart.

I’m having no issues with the shortcuts myself, I use this all of the time. Can you think of anything that might be getting in the way of how the default shortcuts work? For example some French keyboards require shift keys to get the numeral, so maybe the shortcut is actually ⇧⌥⌘8 instead of ⌥⌘8 as printed? Another potential variable: how are you setting the shortcut? I presume just right-clicking in the popup Styles panel and changing the assignment in the contextual menu.

Amber, Thanks for the quick reply.

I set shortcuts in the Format | Styles … menu. They work perfectly for paragraph styles–so well it’s second nature as I write. But when I go into the menu and assign a char style, nada. Nothing weird otherwise in my setup. I’m in Philadelphia.

Possibly related: when I color the text using the color swatch in the format bar I can’t easily clear it. “Clear style” doesn’t do it. Resetting to default “no style” doesn’t either. Maybe I’m expecting too much.

I’ll look at the inline notations. I need them to work with shortcuts. But I find that using char styles (in old versions of Word) is just more convenient, nothing new to think about, very flexible DIY commenting.

BTW, I’ve used Scrivener for years for small projects, but right now I’m working on my biggest writing project ever and Scrivener is saving my ass.

Thanks,

Steve

Strange! The only thing I can think of that would cause a character style to work generally (from menus, panels and such) but not with the shortcut is a shortcut conflict somewhere. You could confirm that by reassigning the intended shortcut to a paragraph style, and see if the paragraph style shortcut stops working. If that seems to be the case, it could be some other program is using that shortcut globally—or maybe even Scrivener. You can look for most such conflicts in the System Preferences: Keyboard: Shortcuts preference pane.

Let’s try this:

  1. Use File ▸ New Project... and select the “Blank” starter.
  2. Once that opens, use the Format ▸ Style ▸ Import Styles... menu command, selecting your main working project.
  3. If prompted, choose to overwrite the styles in the blank project with your customisations.
  4. Lastly, use File ▸ Back Up ▸ Back Up To... and create a zipped copy of the project that you can attach here.

I’ll have a look at your stylesheet setup, and see if I spot anything amiss.

Nothing weird otherwise in my setup. I’m in Philadelphia.

Well hold up, now that you mention it, I’m afraid shortcuts are supported in Philly. Something to do with having unfairly good sandwiches and needing to give the rest of us a little boost to compensate.

Possibly related: when I color the text using the color swatch in the format bar I can’t easily clear it. “Clear style” doesn’t do it. Resetting to default “no style” doesn’t either. Maybe I’m expecting too much.

Yeah I don’t know if that’s related, but to clear text colour settings, right-click on the colour application tool in the Format Bar and select the upper left chip: the one with a red slash through it.

Clearing styles does try to work around direct formatting as in most cases people don’t want to lose italics and such, but it should work if you directly select the text in full.

I’ll look at the inline notations. I need them to work with shortcuts. But I find that using char styles (in old versions of Word) is just more convenient, nothing new to think about, very flexible DIY commenting.

Yeah that’s got a simple and easy shortcut you can use, and the nice thing about it is that inline annotations have built-in behaviours that can be useful during compile. They are also as seamless to use as any kind of formatting, you can switch from notation and back again just as easily as you would switch in and out of italics—so like styles in that regard. Beyond that, they are stripped out of the text by default, so you don’t even have to worry about leaving them around when you’re done with them. They can be omitted from word/char count statistics. They can be left in if you want though, and will generally be exported usefully when doing so (like margin comments in a word processor, though there are options for how they export).

Again though, it’s puzzling that the shortcuts aren’t working in general though, and it would be nice to understand why, even if you do end up preferring Inline Annotations.

Glad to hear Scrivener’s been a boon to your latest and greatest project!

Amber, I’ll try your suggestions. After I hit my word count for the day. I know how to export/import styles so I’ll do that.

Steve

I just want to echo the suggestion of using Scrivener’s built-in facility — inline annotations. You can toggle this on or off a span of text in one stroke and none of the puzzles you are encountering would arise. I use inline annotations to flag blocks of text for attention as well as to type reminders to myself right in the text. Highly recommended!

gr,

Alright already! I’ll give it a try, if you say it’s that convenient. You know how it is, you get certain routines and tricks you rely on when you write and don’t want to waste brain-cycles on figuring out something new when you could be writing.

Thank you for your enthusiasm for this formely-ignored-by-me feature.

I’m still going to try to figure out my original question.

Steve

1 Like

24 hours later, reporting that I’ve started using inline annotations and (gr was right) I’m hooked.

Side note: I discovered, with some digging, that the words in annotations add to the word count in the footer, but if you hoover over he word count you’ll see the count minus annotations (and footnotes too, I think).

Yes, it does not do live reductions as that would involve adding lag between keystrokes. You can click the footer bar stats text to bring up options, as well as more detailed statistics.

The other place where reductions can be done is in Project/Statistics.... For compile counts, you need to use accurate mode, in the lower left, and have annotations removed from compile to begin with (in accurate mode, all compile settings contribute to the count, even the addition of headings and so forth). There is an option to exclude annotations from counts on stats for the binder selection, as well.