Trouble by exporting In-text citations

Hi,
During the writing phase of my thesis, I have been using footnotes for my citations for the sake of readability. As I’m nearing the end my thesis I’m trying to convert all my “footnotes” citations in “inline footnotes” citations so that I can comply with the APA in-text citation requirements. I’m using dynamic citations from Zotero, e.g. { | Waller, 2011 |p. 39 | |zu:406345:E2WU46XC} which can be converted later (see http://thedigitalresearcher.com/how-to-use-zotero-with-scrivener-part-2/)

The switch works fine within scrivener but I haven’t been able to export my text as a .RTF or .ODT document, without that my citations are shown as footnotes. I’ve been checking again and again the different export settings but it seems that I’ve missed the right combination. I tried my luck on Google but I couldn’t find anything unfortunately.

I would be really grateful, if you could help me of this as I’m relying on Scrivener and time is kind of very precious by now.

Thank you very much!

Happy holidays,

Lionel

I might not be understanding the problem, but it sounds like you have the footnotes set up the way you need in Scrivener, so this aspect is not the problem, but you are having difficulties compiling an RTF or ODT file? Could you describe what is happening? For example, is the compile progress bar halting at a certain point and the software is just hanging?

Or maybe I am not anticipating your expectations for the feature. To be clear, inline footnotes in Scrivener are for the most part a purely preferential device. Some prefer to see their notes inline like that instead of hidden away. In the end, they just end up as footnotes. The one exception to this is that in the compile settings, you can set linked footnotes to behave differently from inline footnotes. This is mainly useful in very niche situations where you need both footnotes and endnotes.

Hi!
Thank you very much for you answer. I’ll try to make it a bit clearer (see below with a typical example). I had a look at the export and it seems to behave fine (it doesn’t block anywhere).
Lionel

==============================
1. How it was before in Scrivener:

We used to understand knowledge as a common ground that we all agre[ed on.]
—> Footnote inspector
{ cf. | Stone, 2012 | p. 4 | |zu:1338955:GCN7G5AC}

=============================
2. How it is shown in Scrivener now:

We used to understand knowledge as a common ground that we all agreed on { cf. | Stone, 2012 | p. 4 | |zu:1338955:GCN7G5AC}

=============================
3. How it gets when it is exported as a .rdf or a .odt file (when I do a simple copy and paste from Scrivener to Openoffice, it behaves the same way):

We used to understand knowledge as a common ground that we all agreed on.1
—> Footnote
1 { cf. | Stone, 2012 | p. 4 | |zu:1338955:GCN7G5AC}

=============================
4. How it should be when it is exported as a .rdf or a .odt file:

We used to understand knowledge as a common ground that we all agreed on { cf. | Stone, 2012 | p. 4 | |zu:1338955:GCN7G5AC}.

  1. =============================
    How I wish it in the end, after using the Zotero/Openoffice Plug-in:

    We used to understand knowledge as a common ground that we all agreed on (cf. Stone, 2012, p. 4).

If you ultimately want an inline citation, then don’t format it as a footnote in Scrivener, but as ordinary text. By formatting it as a footnote, you tell Scrivener that it should have a number and be, you know, a note.

Katherine

Yes, I think that’s basically the problem here. You’ve been using the footnote feature for stuff that isn’t and never will be footnotes. Since the footnote feature is naturally designed for generating endnotes and footnotes, you’ve landed in a somewhat difficult position of having hundreds of bits of text assigned incorrectly.

It’s a bit of a pickle, because there isn’t a really good way of converting batches of footnotes into normal text in such a way that they will be placed inline as you require. The best solution that I can think of would hinge upon you having never used inspector comments for their intended purpose. If that is the case, then here is what I would suggest: instead of converting the inspector footnotes to inline footnotes (which changes nothing about their functionality), convert them to inspector comments, first. You can do this by selecting the footnotes in sidebar en masse and then right-clicking and converting them via the respective contextual menu command.

Now, from here we can then convert these inspector comments to inline annotations, and you’d already be very close to what you need, but there is one thing you’ll want to do first. Scrivener will colour the text of inline annotations (and inspector comments) when they are left in the output. This is of course because they are intended to be used for comments, and should stand out from the text. So you’ll need to trick Scrivener into not doing that. With the inspector comments all still selected, right-click again and choose Show Colors, and select pure black using the system colour palette.

All right, the comments will be super ugly and nearly impossible to read, but that’s okay, they won’t be comments for long. Click back into the editor and use the Format/Convert/Inspector Comments to Inline Annotations. Since we chose pure black for their colour, the resulting inline annotations should be black text as well (rather than yellow, red or whatever they would have been if we left the comments their default colour). Your placeholders should now appear highlighted in a bubble (not unlike inline footnotes, but without the background fill).

Finally, you’ll need to alter your compile settings to allow inline annotations to be printed in the output, and to do so as “Inline comments” from the Export to RTF as drop-down. Go into the Footnotes & Comments pane and set that up at the bottom. Just leave the Enclosing Markers fields empty—otherwise you’ll get something like [ { cf. | Stone, 2012 | p. 4 | |zu:1338955:GCN7G5AC}].

That worked pretty much fine, thanks a lot!
The only thing is that the point is not really at the good position as it is positioned before the brackets and not after, but there is nothing to do against it I suppose.
Happy Holidays!