Trouble exporting to MOBI

In RC11, the option to export a MOBI files demands the installation of a KindleGen, which is an obsolete software which is no longer available for download. It has been replaced by Kindle Creator, and it seems Scrivener doesn’t quite work with this one.

Anyway, I know the devs are working on a million things at once, and I understand this might not be a super high priority. Just though I’d let you guys know (:



FWIW, KDP now recommends submitting in ePub format. I realize that doesn’t give you the .mobi preview the Kindle tools did (though you still can on Mac) and you’d have to do a thorough check once KDP have done the conversion and published. A bit arse about but doable.

When you follow the link in Scrivener to the Amazon KindleGen page, that will redirect you to the download page for Kindle Previewer. Although KindleGen is no longer a separate download, there is an updated version of it bundled deep in Kindle Previewer. On my machine, the directory for it was:

C:\Users\devin\AppData\Local\Amazon\Kindle Previewer 3\lib\fc\bin\KindleGen.exe

I was able to click the “Choose” button and provide that path, and Scrivener RC11 then showed the normal options:


Wow! That worked like a charm!

Thanks a lot :smiley:

Not a problem, happy to help. Enjoy!

Unfortunately it didn’t work for me. I can work out where my KindleGen file is on my computor, which is in Users/CMB/AppData\Local\Amazon folder, but the ‘choose’ option won’t allow me to drill down to the file. Bizarre!
[attachment=0]scrivener screenshot.JPG[/attachment]

Not really. You need to turn on “Show Hidden Files” in File Explorer because AppData is normally hidden.

Done that but still the same as before and doesn’t show AppData for me. :frowning:

Instead of trying to click the AppData folder that you cannot see, can you just type AppData in the navigation box?

Type %appdata% into the Windows 10 search bar.

No the issue is still whatever you type into Scrivener’s field called ‘KindleGenfile Executable’ it has to relate to a directory where the file is located on my PC and this just isn’t showing .

Very frustrating. You would have thought that they would have updated the software by now as Kindle Gen has been obsolete for a while now.

The %appdata% is a Windows shorthand to go to the location of your AppData directory, which is a per-user directory that exists as a hidden folder inside of every user’s directory since Windows Vista; it provides a way to install programs and data on a per-user basis so that users don’t necessarily need to have admin rights on the computer.

When you have the selection dialog open, literally paste the string “C:\Users\CMB\AppData\Local\Amazon” (without the quotes) into the “Look in” field. This should allow the dialog to locate the correct folder and let you continue the process of selecting the Kindlegen executable.

Part of the problem is that Amazon isn’t leaving some of the normal clues about where it’s installing its tools, so Scrivener has to trust the user can point it in the right direction. Still, it would be nice if it would check the AppData path and at least see if KindleGen.exe was there and ask if the user wants to use that copy.

Hi Devin,
Thanks for your continuing contribution to try and help me solve this.

Unfortunately I can enter what I want into the dialogue box but it will only offer ‘open’ if I click into a relevant file above, and here is where the problem lies. Despite doing all that has been suggested I cannot get it to show the location of my Kindle previewer in my users directory.

To be honest, I’m better off to just compile as an epub and convert to mobi elsewhere or simply upload the epub file into KDP.

Hi “Entanglement” – if you want to check how a mobi version of your book works before uploading anything to Amazon, you can prepare the epub version, open Kindle Previewer application and just drag the epub file into Previewer.

Previewer will convert the file and enable you to check it out pretty thoroughly in tablet, smartphone versions. You can then export it from Previewer as a .kpf file and then upload the kpf file to Amazon KDP.

If you try to go to that same location in Windows Explorer, can you actually get there?

Drop me a private message here if you want to do further troubleshooting to sort this out at some point – we can fire up a Zoom session and walk through it if you want (I always want to dig into problems like this because they can be symptoms of a larger issue.)

I understand and respect the desire to just get to some sort of workflow that works so you can move on, though!

Thanks for the offer Devin, but I’m happy enough to just produce an epub and process a mobi via one of the various options.