Trouble importing fonts

Hi! I’ve been having trouble for the past few days trying to import a font (Garamond) onto Scrivener for iOS. I’ve been using this font on my Mac and it’s unavailable on iOS, so I used this guide step by step to install the font and it still won’t work: https://scrivener.tenderapp.com/help/kb/ios/using-fonts-across-platforms

I even get the “Garamond was successfully imported” screen and yet it’s nowhere to be found on the Scrivener iOS app. Has anyone had this issue/is there another way to import fonts successfully?

Hi gabbinks,

That Knowledgebase article lists 4x different methods for loading fonts to iOS Scriv. It would help to know which one(s) you’ve tried.

Also, is your font in TTF or OTF format?

Jim

Hey Jim,

I tried all the listed methods – importing individually/manually, using Dropbox, and using Airdrop. Also, it’s in OTF format (should’ve mentioned that before!)

– Gabby

Hi Gabby,

As a test, I copied Garabond (TTF) from my Windows PC to the C:\Users\USER\Dropbox\Apps\Scrivener\Fonts Dropbox folder, and after syncing, Sciv iOS was able to use it.

Make sure after copying that you close and reopen iOS Scriv, and force it to sync.

You may want to reboot your iPad, but that shouldn’t be necessary.

If none of that works, I’m not sure what’s going on with your iPad, but suggest you try installing the font as a Configuration Profile from FontSquirrel.

  1. Using Safari, navigate to https://www.fontsquirrel.com/fonts/eb-garamond

Note: Must use Safari for this, as other browsers may not work

  1. You should be at Font Squirrel’s EB Garamond page. Click “Install on iPad”

  2. Warning “This website is trying to open Settings to show you a configuration profile. Do you want to allow this?” Click “Allow”

  3. “Install Profile” screen. Click “Install”

  4. Enter your iDevice’s passcode

  5. Warning “The profile is not signed.” Click “Install”

The profile for EB Garamond should now be installed on your iPad.

Launch Scrivener and see if the font is accessible.

HTH,
Jim

I am running into the same issue. I first installed the font as a profile via a third-party app and confirmed that it is showing up in other apps, but no luck in Scrivener. I then found these directions and attempted two different methods (importing via AirDrop & through email/cloud service). In every instance I received a notification that the import was successful, even getting notifications that added “-2” and so on after subsequent attempts. Still, after restarting the app & my iPad, the imported fonts aren’t showing up. Any solutions discovered?

There’s a new iOS API for accessing profile fonts, and Scrivener iOS hasn’t been updated since its introduction. I’ve had to delete the fonts I want in Scrivener from my iOS profiles, after which fonts installed via AirDrop or cloud service function correctly. Adding back the profiles kills the fonts in Scrivener. To say I’m frustrated is to put it mildly.

Silverdragon, you’re saving my hide today!! Many, many thanks! Man, these forums really are the best.

Glad my obsessive font twiddling has proven useful!

If it’s any comfort, Scrivener is not the only popular iOS writing app with this problem. The other app I use extensively has less excuse—it’s been updated a few times but this problem hasn’t been addressed. Grr.

:slight_smile: haha, indeed! I’m glad to know I’m not alone in obsessive font twiddling!