Trouble Inserting Images to Project

Hi guys and gals!

I’m working on a new novel, and am in the process of filling out character information. I’ve created a new project using the novel template, and am trying to insert images. When I do so, I get a message saying that text files will be converted to RTF, and media files are not supported in Manuscript folder. That’s fine. I’m trying to insert them into the Character folder, either as a new file or (preferably) an image inside the specific character file itself. I want to use it as a reference when writing out the individual.

The issue I’m facing is that when I insert the image in the file, it adds a link that takes me to Paint to view or edit the file. When I add it to the character folder, it creates a file that just has a similar link that takes me out of Scrivener.

I’ve looked for a few hours now on google and this forum, but I have not been able to locate an effective answer for where I’m goofing up. I’d greatly appreciate nay assistance I can get. Cheers!

What is the image file type?

Can you try to do the same with a *.jpg image and see what will happen?

The image files are .jpg format. The file size is actually pretty small, about 80kb or less if I recall correctly.

That’s odd.

There was a similar post here, in the forum, a while ago. What happened was, that the file the person was attempting to import, was somehow corrupt. Can you try with a different file? Just drag & drop it inside your binder, somewhere outside the manuscript folder.

Yeah, I can do that when I get home. If that doesn’t work, I’ll take a couple screenshots and post them here.

Here’s what I do:
I save the images in my pictures folder under: pictures/[project name]

That way all the related images are together.

Then do edit/ insert image linked to a file. and point to the file. The image is not in Scrivener but in my pictures folder. However, it appears as if inserted when I look at the appropriate scrivener document and I’m not taken out of scrivener.

This does make my scrivener project become divided into 2 places, images in pictures and the documents in documents. I don’t find this an issue. However, it requires that the folder structure remains the same, and if I change image file names, then I have to delete them from scrivener and link again to the new name. I’m hoping version 3 will resolve this issue or make it easier to make the change, since I’m always forced to rename the images.

Below is a couple of screenshots of what it looks like when I insert a picture into Scrivener. I’ve tried two different jpg photos, both with the same issue. It doesn’t give me an error though, just shows up like this. I want to be able to actually see the picture inline with the document I’m editing. Is there a setting somewhere I haven’t stumbled upon that I’ve left un/checked? It’s seriously one of the first tasks I was hoping to do with the program and I’m losing my mind.


I don’t know what the deal was, but reinstalling the program fixed it immediately. If anyone has seen anything like this, I’d be curious to know what’s up. Since I was able to get around it though, I felt like I should let you know.