Trouble running beta 025

I’ve followed the instructions in the wiki for installing the tgz file. When I try to run Scrivener from the terminal it pauses for a couple of minutes and then I get the following error:

QtToolBarManager::restoreState(): cannot find a QAction named ‘Insert Table’, trying to match using ‘text’ instead.
QtToolBarManager::restoreState(): cannot find a QAction with matching ‘text’ (looking for ‘Insert Table’).

This is the output from running ldd /usr/local/LiteratureAndLatte/bin/Scrivener => (0x00b97000) => /usr/local/LiteratureAndLatte/lib/ (0x00c09000) => /usr/local/LiteratureAndLatte/lib/ (0x00874000) => /usr/local/LiteratureAndLatte/lib/ (0x00110000) => /usr/local/LiteratureAndLatte/lib/ (0x002f3000) => /usr/local/LiteratureAndLatte/lib/ (0x00933000) => /usr/local/LiteratureAndLatte/lib/ (0x01e98000) => /usr/local/LiteratureAndLatte/lib/ (0x00572000) => /usr/local/LiteratureAndLatte/lib/ (0x1cd5b000) => /lib/i386-linux-gnu/ (0x006ff000) => /usr/lib/i386-linux-gnu/ (0x009ea000) => /lib/i386-linux-gnu/ (0x00169000) => /lib/i386-linux-gnu/ (0x0018f000) => /lib/i386-linux-gnu/ (0x003a6000) => /usr/lib/i386-linux-gnu/ (0x001ab000) => /usr/lib/i386-linux-gnu/ (0x007b4000) => /usr/lib/i386-linux-gnu/ (0x001b5000) => /usr/lib/i386-linux-gnu/ (0x0023b000) => /usr/lib/i386-linux-gnu/ (0x1b257000) => /lib/i386-linux-gnu/ (0x0024a000) => /usr/lib/i386-linux-gnu/ (0x0025f000) => /lib/i386-linux-gnu/ (0x00264000) => /lib/i386-linux-gnu/ (0x12620000) => /usr/lib/i386-linux-gnu/ (0x0026d000) => /usr/lib/i386-linux-gnu/ (0x00275000) => /lib/i386-linux-gnu/ (0x0028d000) /lib/ (0x00beb000) => /lib/i386-linux-gnu/ (0x00291000) => /usr/lib/i386-linux-gnu/ (0x002bb000) => /lib/i386-linux-gnu/ (0x00507000) => /lib/i386-linux-gnu/ (0x002d4000) => /usr/lib/i386-linux-gnu/ (0x002d9000) => /usr/lib/i386-linux-gnu/ (0x00bc2000)

I’m running Ubuntu 11.04
Linux mr-netbook 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux

uname -a

I deleted the directory for the old version before installing the new one.

Your previous version worked for you, is that right? I just installed Beta 025 and it all works fine. I did not delete the previous version. When you install using sudo it just overwrites the files that have changed. Perhaps if you find the last Beta install it and reinstall 025 it will work for you.

You’re right, 024 worked fine.

I still had the TGZ file so I tried installing that, and then copying 025 over that. Unfortunately the same thing still happens. A long delay and then the error message from QtToolBarManager.

Also I tried downloading the beta again, in case the file had gotten corrupted the first time round, but that’s still the same.

The problem is I don’t really understand the error message. I tried googling it, but that didn’t return anything relevant.

Also running Ubuntu Natty 11.04 (2.6.38-8-generic).

No trouble with 2.4, started and ran quickly, smoothly. Beta 2.5 is so far unusable.

Tried extracting LinuxScrivenerBeta15.tgz (2.5) over working 2.4. No joy:

  • 1:36 start up time
  • In the Inspector, synopsis and notes seem to work as expected, but it’s impossible to enter text into a new document.
  • Cursor does not display in document window
  • Text can be entered into a document with pre-existing text, such as a character template, but
    • cursor does not display
    • selected text disappears
  • Footer will not display
  • Full-screen mode dims the background but doesn’t display the page

At this point I stopped finding problems and tried re-installing.

  • Rebooted
  • Extracted 2.4, then 2.5 over it
  • Created shell script to load libraries
    Ran the script and waited. Same problems.

My guess is that at least one of the included libraries is incompatible with something installed by Ubuntu, but that’s beyond my abilities. And anyway I’ve got writing to do.

Guess I’ll have to sit at the desk and use the Macbook, which, unlike this little Thinkpad, is too damn big to carry around.

Many thanks in advance to the people who will make Scrivener usable on Ubuntu. :slight_smile:

This seems similar to the issue I had. Which was solved by changing the text colour to black. For some reason it had been changed after the upgrade to be white. It may not be your problem, but it’s worth a shot. :wink:


Thanks, Chris. Seems to be at least part of the problem, still no cursor but I’ve managed to make some text visible.

One problem now is that dialog windows for setting preferences are not displaying correctly. Was hoping to find an xml file somewhere, edit preferences directly, but no luck yet.

I managed to get 025 working by deleting the file ~/.config/Scrivener/Scrivener.conf so I guess something in there was conflicting.

However I closed scrivener down and tried running it again and it failed silently without any error messages.

I deleted the conf file and it worked again (though it takes about 3 minutes to start up).

So the outcome is I need to delete the Scrivener.conf file before trying to run it. Once it’s running I haven’t noticed any of the problems that jcartland has.

SOLVED for me! (except for that two minute startup…)

The white-on-white text and other oddities were resolved simply, by clicking on the Defaults button, at the bottom of Tools->Options. But it was still screwy. Things like refusing to open some projects, opening others without complaint. Something wrong with Dropbox and the lock files-- a project wouldn’t open in linux, but then the Mac would complain that it was already open.

Searching for config files, I found them all over the place. (I’ve been messing with this since the first beta, and have made several unsuccessful experiments…)

Here’s what brought me to present happy state:
First, clean up

Hope this helps someone else. I’m now happily working on one project, stored on Dropbox, from both the Mac on desktop and Ubuntu Thinkpad everywhere else. Very much worth jumping through beta hoops!