trouble with some URLs

I’m haveing an issue with some references. When I drag and drop some URLs from Safari, quite a few of them are not able to be opened. The reference shows up with the correct URL but then I get an error message saying it can’t open it. I get the message:
Reference could not be opened.
“The reference could not be opened from the specified URL.”

After exploring a bit, I think that they are URLs that end with php or xml, which I know are rss feed and forum protocols. Is this the way it should be? I am able, of course, to drag the URL directly to my Research folder and it works as expected. But I may just want to associate the URL with a file and not actually import it.

Could you give me an example of URLs that cause problems?

Thanks!

Actually, forget it - I made a stupid mistake. This is fixed for beta 2. Any URLs you have already dragged in you will be able to open with beta 2, too.

Great that it’s fixed! Glad it was something simple.

And next time I have a tech issue I’ll include an example in case you need it. Should have thought of that.

I’ve been struggling with this behavior - I’m pretty sure it is a bug, but maybe it is just a limitation in Safari, so I wanted to chime in here before I filed it in bugs.

In 1.0RC5, if I drag say the blue link “FAQ” from within this Safari page into my Scrivener Research binder, Scrivener imports the page.

If, however I navigate to the “FAQ” page and then drag the URL from the Safari URL bar into my Scrivener Research binder, it pops up the Import Files warning (which I’ve left unchecked - this doesn’t happen in the first case) followed by:

I cannot recreate this. How are you dragging the URL in? If you drag it from the favicon, it works. You only get this pop-up if you drag in something that Scrivener does not recognise. It seems as though Scrivener has taken the page you tried to drag in for something it does not regonise. Perhaps a PHP page or some such?

Best,
Keith

Nope, definitely happening with HTML etc. Here are instructions to recreate:

  1. Open Scrivener 1.0RC5 (Settings: Convert HTML files to text, Convert Webarchives to text)
  2. Create new project: safaridragtest.scriv
  3. Navigate Safari [Version 2.0.4 (419.3) on 10.4.8] to an HTML page: w3.org/MarkUp/Guide/Overview.html
  4. Click and drag URL bar favicon onto Scrivener “Projects” folder in Binder

Result:

Error message displays, nothing is added to Scrivener Binder. Note that dragging an in-page link to the same page functions as expected, importing the page.

Mea culpa - I forgot that I use Camino all the time, which works fine. Yeah, Safari doesn’t work in this regard. Having tested it, it turns out that Safari doesn’t put the URL on the pasteboard properly. That is to say, for some reason, Apple’s web browser does not place on the pasteboard the standard Apple URL date - d’oh! So this is just an oddity of Safari. Like I say, it works fine with Camino…

Incidentally, there is, I have just realised, a slight oddity in this regard currently - if you drag a URL into the binder from Camino, it gets imported as a webarchive regardless of your import options. This is because dragging a URL in uses a different mechanic. I’ve added it to my list of things to address, but just something to be aware of.

Best,
Keith

In Firefox, dragging from the URL bar just creates a new document with the URL as the first line of text. Dragging a link from the page does the Camino thing where no matter what your preferences are, it will be a WebArchive. That would make sense, since both Firefox and Camino are using the same HTML rendering guts at that point. The other part is application specific.

I’m keeping an archive of threads from Adobe’s Illustrator forum in preparation for writing a book on advanced techniques. Unfortunately, when I try to import the page, all I get is the URL displayed at the bottom of the Scrivener window. The web pages are a mix of text and graphics, including examples that are necessary to include. I get the same result in Safari, Camino, and Firefox: just the URL at the bottom and no text or images. I’ve been reduced to taking screenshots, which is obviously not the best method. Is there a way I can get around this problem?

Post a URL that is causing problems and I will look into it.
Best,
Keith

Here are two of them:

adobeforums.com/cgi-bin/webx/.3bc30294/0

adobeforums.com/cgi-bin/webx/.3bc2fe1d/0

I should also add that I’m already logged into the Adobe forum when I try to pull in the pages.

Huh… This is a really weird one. It seems that for some reason, the code I am using to check if a URL is a valid web page messes up the import for these. I check the part of a page, and if it is not valid, throw an error that the URL is not valid. But in the case of these web pages, this code messes things up so that only the head part of the page gets imported. I have absolutely no idea why this is the case - some intricacy of the WebKit that is beyond me, it seems.

Anyway, for 1.01, I check the whole page rather than just the HEAD. This means that it will take longer to validate web page imports, but the URLs you posted will import correctly, at least. Until 1.01, as a workaround, you could use Safari’s Save As… feature to save the web pages as webarchives and then drag them into Scrivener’s binder manually.

Thanks,
Keith

Of course I’d expect such weirdness from Adobe. :slight_smile:

Thanks for looking into it. I’m still on the trial for Scrivener, but just the fact that you replied and looked into the problem so quickly convinced me to register before the trial ends. Thanks very much.

No problem. :slight_smile: And like I say, with the next update (which will be out within the fortnight), these Adobe pages should no longer be a problem.
Best,
Keith

Hello Forum,

I’m new to the forum, but not new to Scrivener. I like it as my favourite writing tool. But that’s why we all are here. So here is my problem:

Importing webpages is a great feature and works for all standard webpages. But there’s a new illness on the web: german “umlauts” in the url of a page… (german “umlauts” are - ä, ö, ü)

Here’s an example: de.wikipedia.org/wiki/Hüls_(Krefeld)

(As you can see, the forum won’t recognize it either!)

I wanted to import it as a webarchive, but Scrivener won’t do that. I think, it’s because the “umlaut” in the url.

Thanks for every workaround!
Marcus

Uhh, Im sorry!

Seems to be a browser specific problem! In OmniWeb the url appears as follows: de.wikipedia.org/wiki/Krefeld-H%C3%BCls

The “umlaut” is “hidden” in code. Ok, problem is solved, as long as OW will hide the “umlaut”. For the first importing attempt I used Opera.

I’m sorry for the bafflement.
Marcus

Glad you found a solution!
Keith