Trying to compile and replace my manuscript empty lines with no empty lines

My manuscript looks like this:

[i]Lobsters were not very clever. Instead of backing deeper into their holes at the first sign of a human, they boldly faced the threat. Since spiny lobsters had neither claws nor any other form of defense they were usually easy prey.

This time, Hatuey was lucky and found two large lobsters sharing the same ledge. With a practiced grab of their carapaces, Hatuey ascended with tonight’s dinner in each hand. Dropping them into the dugout, they flicked their tails and rasped their displeasure. [/i]

I want it to look like this after compiling:
—indent----> Lobsters were not very clever. Instead of backing deeper into their holes at the first sign of a human, they boldly faced the threat. Since spiny lobsters had neither claws nor any other form of defense they were usually easy prey.
—indent----> This time, Hatuey was lucky and found two large lobsters sharing the same ledge. With a practiced grab of their carapaces, Hatuey ascended with tonight’s dinner in each hand. Dropping them into the dugout, they flicked their tails and rasped their displeasure.

Note: I had to use, “—indent---->” to represent an indent, as this forum sw kills empty spaces preceding text.

I have figured out how to do the indent, but I’ve tried everything to remove the empty line and cannot figure it out. My paragraphs are always separated by an empty line.

If paragraphs are separated in the editor with two returns, you can remove these during compile by setting up a replacement that searches for two returns and replaces them with one.

Use OPTION RETURN to type each return in the replacement interface: you won’t see the characters represented on screen, but they will be there.

Hope I haven’t misunderstood.

I didn’t realize that the Compile could search/replace - that will probably work. I’ll test it.

thanks!
ken

The compile replacement must be happening first - before the rest of the formatting rules because I just get everything combined out of the compile. I guess I only wanted an “empty line” rather than all carriage returns. I’ll see if a RegExp can tackle this.

ledge. Lobsters were not very clever. Instead of backing deeper into their holes at the first sign of a human, they boldly faced the threat. Since spiny lobsters had neither claws nor any other form of defense they were usually easy prey. This time, Hatuey was lucky and found two large lobsters

Success!

You need to do this:
search term: \n\n
replacement term: “OPTION return” - you don’t type this, you just press the OPTION and return key once - you won’t see anything in the field, but it is there

Select “RegEx” and then go ahead and Compile.

Hey, ken.

For me, I just key OPTION RETURN OPTION RETURN (i.e. key the combo twice) in the “Replace” field and OPTION RETURN once in the “With” field, and that works fine. But, yes, RegEx also works as you describe.

Come what may, glad you got it to work, and hopefully this thread might help others in the future,