Turn off Auto Suggest

Hi, I just upgraded to MacOS 14.1, and I noticed a change in the way Scrivener 3.3.6 works with it. When I type I get suggestions for word completions. (E.g. I would have typed “comp” and it would have suggested a word that began with “comp” that may be the word I was going to type. I find it distracting when I’m writing. How do I turn that off? I went to Settings>Corrections and turned off auto completion, but it still is suggesting how I might finish a word I’m typing.

Thank you.

Hi MDVD, and welcome to the forum.

The predictive text tool you’ve encountered is actually a macOS tool, not one from Scrivener.

On the macOS, you can go to System Settings > Keyboard > Text Input > Input Sources and click the “Edit” button. Here, you’ll want to toggle the “Show inline predictive text” tool so that it’s not highlighted.

That will turn off predictive text throughout the macOS in all apps.

If you want to use that setting in most other apps but not in Scrivener, you can go to Scrivener > Settings > Corrections and tick the box under “Auto-Completion” next to “Only suggest completions from custom auto-complete lists.”

2 Likes

That seems to have fixed it. Thank you so much!

1 Like