Turn on Windows 7 Compatibility mode?

Scriv is not responding when I try to open a project file.

I’ve found several of the other posts on this topic and want to turn on Win 7 compatibility mode.

Where do I find that setting?

Thanks!

Marsha

Right-click the Scrivener program icon and choose “Properties”, then the “Compatibility” tab at the top. Check “Run this program in compatibility for” and select the Windows version you want to use.

I hope that gets it working!

Thank you!

I changed the setting and restarted.

It still doesn’t open for several minutes, then doesn’t respond when I click on the project that loaded or any where else.

The program icon stays yellow in the task bar and the cursor keeps swirling.

Does that give you any clues?

Thanks for your help.

Marsha

If it’s auto-loading a project, it may just be something in that project that’s hanging on load. Try renaming the project’s .scriv folder and then launching Scrivener, so that it will skip opening that project (just click OK to the message that it couldn’t find the project–that’s expected since you changed the name).

If you’re able to get to the New Project window, try opening or creating a different project. If that’s all working, you could try again to open your original project, once Scrivener is already opened. It could be that there are a lot of files loading at once–for instance if you had left your project open in a large Scrivenings view–and that combined with opening the whole program just stalled out. If the project still won’t open even with Scrivener already started, it would be time to check for a corrupt file in there (e.g. a recently imported PDF) or reset its appearance so that fewer files are loading into the editor.

It is an auto loading project.

This makes a lot of sense. Will use these suggestions and report back.

Thank you!

Marsha

Hello again,

I followed your instructions and changed the project name and started in a fresh, empty project.

I removed two PDFs that may have been causing problems.

Three questions:

  1. How do I reset the appearance, as suggested, so that fewer files are loading into the editor?

  2. How do I troubleshoot corrupt files?

  3. Please define a large Scrivenings session, and how I reduce it.

Many thanks for your assistance.

Best,
Marsha

Back again.

After doing the above, Scriv freezes and won’t open a bigger file. I get that it’s hanging up somewhere, but I don’t know the program well enough to troubleshoot.

I’m including a screenshot. Freezing on opening this file – a couple pages of text only – has happened several times.

Thanks for your guidance.

Is the project loading at all now, or is it still stuck? If it’s loading, “reseting the appearance” would really just mean making sure that when you close the project, you don’t leave it with a lot of items loaded in the editor–for instance, if you have a lot of Research items, avoid leaving the Research folder open in the corkboard with all those items (especially images) loaded as index cards. Just switching to a single item rather than a whole folder in group view mode will fix this.

If you’re not able to load the project, you can reset it to the default appearance by removing the “ui” file from the project’s “Settings” folder inside the .scriv folder. I’d just drag it to the desktop for now rather than deleting it, so you can see if removing it works to load the project. This will reset all your project-specific appearance settings like whether labels show in the binder or what size the index cards on the corkboard are, but it will also reset what loads in the editor, so should fix that problem. Alternatively, if you’re comfortable editing the ui.ini file, rather than removing it, you can open it in a text editor like Notepad and find the following lines and change them all to 0:

firstEditorSource=0
secondEditorSource=0
[...]
groupMode=0
secondGroupMode=0

Save the changes and then reopen the project. That will set it so that the Draft folder is loaded but not in a group view, so you’ll just see the blank editor with an icon in the middle saying “Draft Folder” (or whatever you have renamed the Draft in your project). From there you can select another item to load in the binder, switch the group view to corkbord or outliner, etc. All your other project appearance settings will remain as they were.

To find corrupt files, you could try a few things. With the project closed in Scrivener, you can just go through the project’s Files/Docs folder and check whether the items load in their default editor–e.g. if the image file won’t open in your Windows image editor, it’s likely damaged. You could just remove the file from the project folder, then reopen the project and delete it from the binder (once it’s removed from the Files/Docs folder, you’ll be able to click it in the binder without anything happening; it’s just an empty placeholder, with nothing to load in the editor). Presumably if the project not opening is caused by a corrupted content file, it would be one that you had opened when you last worked in the project, so if you sort the files in File Explorer by modified date, you can easily check the most recent.

If you get the project open from changing the appearance settings, you could just take the approach of clicking through your binder to load each item, and if Scrivener crashes, you’ve got your target. :wink: I’d make a backup first, File > Back Up > Back Up To…, so you can click around without fear.

“Large Scrivenings session” is subjective, but I was thinking something like having your full Draft or Research folder loaded, 20+ documents making up the session, or lengthy in the sense of word-count, if you have three documents of 40K words each. None of these is necessarily bad, but if you’re having trouble it’s worth trying to trim the Scrivenings session to fewer documents or break your documents into smaller sections, to see if that helps.

Whoops, I got distracted in the writing and now that’s all old news. Are you freezing when you load the “Guides” folder or when trying to load the “Outline for forests” document? Assuming the latter, try reopening the project and locking the editor (View > Editor > Lock in Place), then select “Outline for forests” in the binder and use File > Export > Files… to create a copy outside of Scrivener that you can open in Word or other word processor, to make sure you have all its text. Then you can move the “outline for forests” document in Scrivener to the Trash and empty the trash to delete it from the project (make sure before emptying the Trash that there’s nothing else in the Trash you want to keep; if there is, move it out of Trash first).

After that you can try a few methods to bring the text from the exported file back into Scrivener. Copying and pasting as plain text (Edit > Paste and Match Style) might do it, if it’s a problem with the way formatting was encoded. Do you know if the document was composed in Scrivener or if any of it was originally imported or copied from another program?

MM,

Again, you are a fabulous resource! Thanks for all of this.

The project does load. It freezes when I try to open the “Outline for forests” document and “Trails: Phase One,” which has a lot of index cards associated with it. And yes, much of the text in the Trails docs were copied from the web so maybe there are hanging up the program?

(We’re talking very low word counts for the most part, several hundred words maybe. No where near 40K or anything manuscript length.)

Is there information in the Knowledge Base that explains the best way to manage Scriv files and settings? Please direct me if so. I see that I need to learn more about how to use the program!

I will work through all of your suggestions and report back.

Many thanks. You rock!

Best,
Marsha

Hello again. I am back.

A new wrinkle: I can get Scrivener to open if I rename the troublesome project and it opens and asks if I want to start a new project.

However, when I click on my problem project Scrivener is frozen and does not respond for at least five minutes. (I timed it. )

When it does load, nothing is clickable. See attached screenshot. Eventually the nav bar came back but still nothing responds when I click on it.

So unfortunately I haven’t been able to try your suggestion to export the file, convert to plain text and import again.

Any suggestions on what else I can do to recover these files and clean out the offensive formatting?

My entire project is in this troublesome project file and it’s making me nervous…

Many thanks for your patient help.

Marsha

Back! SUCCESS!

The project finally opened and I was able to follow MM’s instructions to export the files (as text files), move to trash and delete.

I also exported all the files as text files to be on the safe side.

I copied and pasted one of the offending files from the text file, exited Srivener and then reopened Scrivener.

It popped right open.

Halleluia! Such relief.

Thanks for your patient help. I will be very careful to not import formatted files from here on.

Thanks again!
Marsha

Glad you’ve got it working! Importing formatted files isn’t always a problem, but every now and then there’s just something funky in the encoding that causes a problem. I wouldn’t say as a rule you have to avoid importing all such files, but at least be aware of the potential problems. Resaving files as RTF before importing will often avoid conversion trouble too, and if you’ve got Microsoft Office 2007-2013 installed, you can switch on those import converters for DOC and DOCX import under Tools > Options: Import/Export. They use the Office libraries for converting those formats to RTF, which also sometimes will get around quirks particular to MS Word’s syntax.

If you do need or prefer to go the plain-text route, Edit > Paste and Match Style will do that for you, like the “Paste with Source Formatting” option in Word.

That’s very helpful to know abut the import converters and RTF.

Thanks again.

You saved my arse!

Cheers,
Marsha