Turning off the ruler in full screen? [CONFIRMED]

Hi.

I know that there is a quick shortcut to hide the ruler, but in my full screen view (I’m using the poetry template) it reappears every time I go into full screen. Is there a way to turn it off so that I don’t have to see it unless I want it?

Thanks,

Gregory

Yeah, that looks like a small bug to me actually. Here is how to get rid of the ruler. In the Format/Options sub-menu, de-select “Show Line Numbers with Ruler”. Now toggle off the ruler in the main editor; enter full screen and you might have to toggle it off there as well. It should be gone now.

It looks like the line number option is forcing the ruler to turn on in full screen no matter what.

Keith, to reproduce:

  1. Create a new project with the poetry template
  2. Click on the poem file
  3. Enter full screen
  4. Disable the ruler with Cmd-R
  5. Exit full screen with Esc
  6. Enter full screen

In a normal project, the ruler will be disabled even if it had been on before, the preference sticks for full screen depending on whatever you last set it to. However if line numbering is turned on, the ruler will engage in full screen no matter what, even if you’ve already disabled it in full screen, and even if you have it off in the regular editor too. It will only disappear after you’ve disabled line numbering and then toggled it off.

Thanks. Fixed for 2.0.3.