Two apparent bugs with curly quotes (aka "smart quotes")

Version: Scrivener 3.1.2 for Windows

  1. Within document titles (for my writing, that means chapter titles), Scrivener seems to only allow straight apostrophes, and straight single and double quotes. I cannot find any way to make those quotes to have the curly format. Therefore, every compile means going through my titles in the compiled output (DOCX output) and changing the straight quotes to curly quotes. This does not happen in the body of the chapter.
  2. Under File > Options > Corrections, my (enabled) setting for single and double quotes is //abc// and /abc/. (Imagine those slashes are quote marks; I don’t know how to generate smart quotes in this text field.) I presume these are the default settings, and I just noticed them. Yet, when I type in the editor, the curly quotes appear as I want them, namely, \abc// and \abc/. So the actual behavior does not match the options setting. I haven’t played around with the other various smart quote selections under options, because the behavior, when I type in the editor, is to my requirements.

(Imagine those slashes are quote marks; I don’t know how to generate smart quotes in this text field.)

You don’t have to, as Markdown, the engine used to produce text on the forum here, handles that kind of mundane detailing for you, rather than having to worry about it while writing. I never worry about this kind of stuff while writing in Scrivener, since I use MultiMarkdown/Pandoc to export, and they handle typography on the fly. Maybe something to consider. :wink:

But that aside, yeah you need to learn how to type in stylised punctuation directly, as that’s going to be useful in cases like this where you need them in simple text fields and such. You would need to look that up for your particular keyboard layout. I use an international English layout that puts AltGr on the right Alt, and for me I can force typography with AltGr-9 and -0, and add Shift to that for single-quotes. It’s honestly about as easy as typing in straight quotes once you get used to it.

1 Like