Two Features I Can't Figure Out

Hi. I have been playing around with Scrivener but there are two features I can’t figure out or find answers to in the Scrivener tutorial document or in this forum.

  1. Auto-completion of text. I’ve added a few words to the auto-completion list. However, I can’t figure out how to make Scrivener auto-complete those words when I’m typing. For instance, I added the word “test” and then typed a few letters and expected Scrivener to complete the rest but it didn’t happen. I tried typing a few letters and then the tab key and that didn’t work either. I also tried typing a few letters and then the spacebar and still nothing. Can someone please explain how it works?

  2. Ghost Notes Mode. I can’t figure out what this mode is. Can someone please explain what it does?

Thanks,

Mirskyman

I can’t help you with auto-completion as it drives me mad in any application, so I have it turned off.

But Ghost notes mode is brilliant; it concerns inline notes, i.e. annotations and footnotes. If you turn it on, when you add an annotation (Cmd-shift-A) or a footnote (Cmd-shift-F), while you are editing the contents, the text of that note appears at full opacity, but when your cursor is in the main text, then all the notes are shown at reduced opacity — you can set the level of opacity in the preferences … I use something like 25% — so they appear washed out and much less intrusive in relation to the main text.

If you place your cursor back in an existing note, as long as it is there, the text of that note returns to full opacity.

HTH

Mark

Type several letters; then hit ESCape.

Dave

Hi,

that doesn’t seem to work for me – with Ghost Note mode turned on, notes remain faded out, independent of the position of the cursor and even clicking inside and typing does not return them to full opacity. Settings in the pref-pane are on default. I always turn Ghost Note mode off manually when typing a note, then switching it back on. What could be the cause of that?

OS X.5.7., Scriv 1.5.1., Powerbook G4

Thanks!

js

According to this thread, there is a bug that will be fixed in the next release.

https://forum.literatureandlatte.com/t/ghost-notes-nonfunctional/5877/2

Apollo16

Yes, there is a minor bug with ghost modes that will be fixed in the next couple of weeks; it got broke during some changes I was making in preparation for 2.0. However, it should result in the notes not fading out properly rather than being constantly faded out.

As for auto-complete, this works the same as it does across OS X, which is to say that you need to hit Opt-Escape or Cmd-period to bring up the auto-complete menu while typing a word. I have hacked into the text system to make it possible for this to appear automatically in 2.0 (which will be optional of course).

All the best,
Keith

Great, that thread must have slipped my attention. Thanks!

js.