Two Help Menus

Hi,

I just started learning Scrivener, and am delighted to see that extra effort went into user assistance – see images. Not sure whether this is a bug or a feature. :slight_smile:

PowerBook G4 17", PPC G4 (1.1), 1.5 GHz
Mac OS X 10.5.6 (9G55). More details on request.

TL

Help2.pngHelp1.png

Hi,

This usually indicates that something is going wrong on your machine, in that an error is getting thrown when opening Scrivener causing it not to load properly. Could you please open up the console (~/Applications/Utilities/Console.app) and see if any error message is reported there?

All the best,
Keith

Hi, Keith,

Wow! That’s probably the fastest support response I ever got.

In Console, filtering All Entries with “scriv” displayed:

15.05.09 09:55:52 [0x0-0xf30f3].com.literatureandlatte.scrivener[2535] SimplyBurnsCMPlugIn_PostMenuCleanup( instance: 0x9799a80 )
15.05.09 09:59:46 mdworker[3159] (Warning) ImportPluginLoading: Plugin at url ‘Spotlight/ScrivenerMDI.mdimporter/ – /Applications/Scrivener.app/Contents/Library/’ cannot be loaded. It will not be used.
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_Factory( 0x0, 0x81273f0 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_Alloc( 0x878de10 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_QueryInterface( 0x2e3120, 0xbfffe50c, 0xbfffe558 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_AddRef( 0x2e3120 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_Release( 0x2e3120 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_ExamineContext( 0x2e3120, 0x81add14, 0xbfffea88 )
15.05.09 11:53:13 [0x0-0x31031].com.literatureandlatte.scrivener[362] Not the Finder!
15.05.09 12:16:19 [0x0-0x31031].com.literatureandlatte.scrivener[362] SimplyBurnsCMPlugIn_PostMenuCleanup( instance: 0x2e3120 )

I am running the latest versions of SimplyBurns and of Scrivener.
Since the Bug report I have updated the System to 10.5.7, the issue persists.
Also I note that the “eSellerate install failed” dialog comes up every time I start Scrivener.

TL

Hi, Keith,

Update:
Moved SimplyBurnsCMPlugin from ~/Library/Contextual Menu Items to Desktop and restarted.

New Launch of Scrivener wrote to Console (filtered for “scriv”):

15.05.09 12:38:48 /Applications/Scrivener.app/Contents/MacOS/Scrivener[195] CPSGetProcessInfo(): This call is deprecated and should not be called anymore.
15.05.09 12:38:48 /Applications/Scrivener.app/Contents/MacOS/Scrivener[195] CPSPBGetProcessInfo(): This call is deprecated and should not be called anymore.

So the CM is part of the problem. I’ll get rid of the contextual menus, that’s tolerable, I don’t use them much anyway.
Can I delete ~/Library/Application Support/eSellerate/ without causing problems?

TL

And another one came up:

15.05.09 12:58:19 Scrivener[283] *** -[NSCFArray objectAtIndex:]: index (-1( or possibly larger)) beyond bounds (3)

TL

The first message about GetProcessInfo being deprecated is harmless - this is apparently a Leopard bug which reports this message for a number of programs without causing any problems. The “objectAtIndex” error is more worrying, as that would indicate a Scrivener bug. What are you actually doing when you see this error?

I’m glad the Help file problem came down to an external plugin - that would make sense.

As for the eSellerate problem - although this won’t have any effect over the trial, if you decide to buy, you will need the eSellereate engine installed properly as it is what is used to validate serial numbers. This issue comes up from time to time and it is usually a permissions problem. There is a detailed guide on how to resolve the issue on the wiki, here:

literatureandlatte.com/wiki/ … all_Failed

Hope that helps. Let me know about that -objectAtIndex: error.

Thanks and all the best,
Keith

Hi, Keith!

I will keep an eye on the “objectAtIndex” error. Should you happen to know a trick to get a dialog (or similar) when an entry containing “scriv” is written to console, let me know. All I recall is I was playing with the tutorial up to “Part 2: Organisation”, albeit with some extras (I remember letterbox mode with 300, 600 and 500 px but there has been more fun…).

The Help menu problem was not solved by removing the SimplyBurns CM Plugin, only the SimplyBurns Konsole entries stopped. But read on…

A test on a fresh system (10.6) showed everything OK there without or with registration, so I went radical:

Removed Scrivener, its Application Support, PLIST, the eSellerate Folder, then downloaded and installed Scrivener and eSellerate from scratch.

Fresh Scrivener still had both the eSellerate dialog and the double Help. Re-installing eSellerate cured both (almost sure; I was running repair permissions at the same time – still not finished yet – so it could be the perms, although neither manual inspection of the eSellerate folders perms nor the repair permission log showed any indication that it was the perms).

Console gave one error every time Scrivener started now, until the extras were installed:
15.05.09 15:40:39 Scrivener[1607] non directory file already exists at /Users/tw/Library/Application Support/Scrivener
I guess this is just a silent routine check for App Support files.

Now for the fun of further exploring Scrivener!

Have a fine weekend!

TL

Hi,

Ah, sorry for the misunderstanding. Glad you got it sorted with the eSellerate re-install. I suppose that could have been the culprit, as it is an error, although I thought it would be harmless. The other console message is indeed just a check for App Support files and is harmless, and as you say, installing the Extras fixes it.

I should add that Scrivener hasn’t been tested on 10.6 yet - I have just re-subscribed to ADC and downloaded Snow Leopard on another machine, but I haven’t started proper testing yet. I will be getting Scrivener Snow Leopard-ready over the next couple of months, though, to make sure it runs fine for the 10.6 release.

Have a great weekend yourself,
All the best,
Keith

Hi,

Just a brief feedback:

  • No further errors showed up in Console.
  • “10.6” in my last post was meant to be 10.5.6, sorry.

Scrivener is GREAT!
TL

Thanks for the kind words - glad everything is working properly now.
All the best,
Keith