two issues (well, +) with font size -- and workaround

As promised, Scrivener 1.8beta:

  • Setting font size to 9 or 14 in Options, and then opening a new fragment, I still get the font size 10, indicated and probably apparent, but see further issues.
  • Setting font to be Arial 12 in Options, ctrl-N a new fragment, and it reports Verdana 10, looks 12. Copy-pasting into Word, I get Verdana 12. Wrong a lot of ways…
  • So I hit Defaults in Options. It says this should be Verdana 10. with the usual new fragment, I write, and copy-paste to Word – it looks there to be Verdana 12.
  • Really I started looking at this because I set Calibri 11 in some earlier Scrivener Options, and copy-paste to Word was giving me Calibri 12.
  • There are even stranger errors on early-use fragments, so let’s not look at any of those, per beta.
  • if I set font name and size in the editor, then copy-paste to Word, it comes out correct: Calibri 11 for example.

Upshot: past beta fragment content aside, I can’t seem to successfully set Options for font. Not even the Defaults are obeyed properly. Sizes and fonts in copy-paste to Word appear wrong, but that’s probably just because they were never correctly indicated in the editor (?). You are going to have to look carefully to assure all of these. But see the workaround: I kept going…

Workaround: I found what would do it. In the Font dialog of Options (gained by hitting the Red A), anything you set will be ignored by the time you’ve Ok’d it. But if you select Latin from the dropdown which is preset at Any, after you’ve made your font name and size settings, then the Font dialog settings will be obeyed when it closes (via the small example), the new fragments will come up with the proper defaults, and the copy-paste to Word will give just the same font settings. All ok.

By the way, but important also: Deleting a fragment from the binder leaves the editor on that trashed fragment, even though it’s in the bin. I think chosen fragment and editor presentation should jump to one of the adjacent binder fragments – probably down, except in the case that you only had one above.

Lengthy, I know, Lee, but this way you get the clues.

Best,
Clive

Ok, there’s even more to this. I was correct to bring Word cut-paste into the question, I believe [but believed wrong, see below], as this is where the problem(s) first showed to me anyway.

  • the main part. If you have set a font size and name other than default on the editor, and trash the fragment you are on, and hit ctrl-N to create a new empty fragment, the newly set Editor font size and name carry over – instead of the default being used. for instance Brioso Pro medium and 18 point. Very dramatic :wink:

  • So, I think what I said above about a workaround is a lie. The only workaround there is at present is to set the Editor font size and name in front of you on the element you are editing – then this will be carried over when you create a new fragment.

  • there is a disappearing cursor issue when you change the Editor font. If you have a blank page, you can’t get it back by clicking. Typing however will restore the cursor to normal function.

  • I thought I had one more issue, but it looks not to duplicate, even though I have a picture. We’ll put it down to operator error unless seen again. That’s where I thought Word cut-paste was failing again, in interesting ways, but in the event, apparently it wasn’t.

Cheers, Lee
Clive
not an Old Blightyite either, though lived there a decade…

…and…there is one situation, only I think, where the Options default actually is obeyed.

That’s when you open Scrivener fresh, and have not clicked in the visible text editor.

At that moment, the Editor shows the default in its display, and if you Crtl-N or menu a new Text, that will now be set to use the default in the Editor.