Two of each heading appearing in compiled TOC

Any help would be GREATLY appreciated.

I am trying to compile a .mobi file for a boxed set of stories. Each book is a single document and there are no sub-documents. The list appears in the the left nav column like this:

Manuscript
Story 1
Story 2
Story 3
Exerpt
Booklist
About the Author
Copyright

I begin each story document with a small book cover graphic, title, copyright and brief blurb, followed by a page break and then the main body of the story.

Although these sections are combined as one, when I compile, they appear in the Mac Kindle Reader TOC (left column nav) as separate sections, i.e.:

Story One (contains graphic, title, blurb)
Story One (contains main body of story)
Story Two (contains graphic, title, blurb)
Story Two (contains main body of story)
Story Three (contains graphic, title, blurb)
Story Three (contains main body of story)

They appear in the regular TOC as:

Story One (contains main body of story)
Story One (contains main body of story)
Story Two (contains main body of story)
Story Two (contains main body of story)
Story Three (contains main body of story)
Story Three (contains main body of story)

I have tried with and without page breaks, compiling with different settings, but nothing is helping. I’m ready to dump this whole thing and go back to StoryMill.

Extremely. Frustrated.

Nothing is helping…can you? :slight_smile:

Thanks in advance!

Robyn

What I would recommend is creating your own table of contents. The dynamic one is nice, but it has to do its best to guess at what you want, and it isn’t always right. So try just selecting the items you do want in the ToC, in the Binder, then use the Edit/Copy Special/Copy Documents as Scrivener Links menu command.

Create a new document called “Contents”, and paste that list in. This will by default replace the HTML ToC that you can flip through in the book content. If you’d rather call it something else, you can do so, just be sure to update the option in the Layout compile option pane where it asks for the name of a custom contents file.

Thanks, Amber. I tried that, but unfortunately the TOC only shows the body of the story, and not the first part (the cover image, blurb, etc.). I can’t figure out why Scrivener keeps separating these sections, when I have them all in one file. I’ve checked to see if I have some weird formatting in there, but nothing appears out of the ordinary.

Oh it’s breaking in the middle of a file; sorry I thought you had the intro in a separate file. In that case do a scan for page break characters. Use Format/Options/Show Invisibles and scroll to a spot where it breaks. Do you see a blue bar in between any paragraphs? It will be small, like a slightly thicker cursor. If you want to see what one looks like, with invisibles on, use the Edit/Insert/ sub-menu to place one manually.