Typeface problems on scripts

I am using Scrivener at the moment to write a playscript in verse. I’ve found that I can start a new indented line using COMMAND-OPTION-RETURN without starting a new paragraph, which works very well for verse dialogue. However there are two problems that happen occasionally:

  • If I use the above key combination but click away and then back, sometimes the current typeface switches to a sans-serif typeface from Courier and deleting the newline and pressing return again does not always cure the problem.
  • Cutting and pasting or dragging text around at the end of a line that has been indented in this way sometimes turns the line to all caps, which does not go away with ‘undo’ and it seems can only be cured by deleting and typing the text all over again; in fact my attempts to get rid of it any other way have usually resulted in other lines or even the whole paragraph becoming all caps.

I am on a MacBook using OS X 10.4.11

Hi,

I’m having troubles reproducing these problems. 1) sounds like an OS X typing attributes issue, so I wonder if it is a little different between Tiger and Leopard. It sounds as though when you click away and then return back, it is returning to the default font. This is possible if there is no text after it. 2) should only happen if you paste into a line that is supposed to be all caps. If you can give me the exact steps to reproduce (a step-by-step breakdown) I’ll take a more in-depth look at it, though.

Best,
Keith

I just set up a new document in UK script format:

Between each line in the dialogue, I used CMD-OPT-RETURN to preserve indenting.
I highlighted the second line of dialogue like so:

I then dragged this to the end of the third line and as soon as I let go of the mouse button, the whole line turned to caps like so:

The ‘convert to lower case’ menu option has no effect on this text at all.

Fixed for 1.12.