Typewriter Scroll Line setting not working

I cannot figure out what I am doing wrong. I cannot get the Typewriter Scroll Line setting to take. I have tried it in both Composition Mode and regular Editor mode. I have tried it on documents that have a lot of content and a little. No matter what I do, it just stays at the bottom of the page I am writing even though I have it set for Top quarter of screen in preferences.

You mentioned “bottom of the page”, and although that isn’t applicable to Composition mode, I just wanted to make sure you were not in Page View mode. These two functions are not compatible with one another. You have to be using wrap to editor mode for typewriter scrolling to work. If you are in standard wrap mode, then make sure there is a checkbox beside “Typewriter Scrolling” in the Format/Options/ sub-menu.

If you are in page view (and therefore can’t use typewriter mode), you can still have that look.

Preferences > Editor > Wrap To Editor Mode and tick the “use fixed width” box. Then make the width of your editor such that it looks like Page View mode. (You can change the color of the background behind the page in Preferences > Appearance > Editor > Fixed Width Background).

What you end up with is essentially Page-View, but it’s as if you have a big roll of paper in the typewriter instead of just one page.

I love this mode.

Thank you!! I will check all that out . . . tomorrow. Too late tonight. I appreciate the responses.

I guess this would be a good wish list item then. Typewriter in page view. Typewriter scrolling is for me one of the best things about Scrivener, and it’s one of the things people get excited about when I show the program to them. Why wouldn’t it be there in page view? I like to edit in page, even though I know they aren’t exactly how it would print or export to Word. It still helps me see my progress and I like knowing what page I’m on, roughly. Plus, it just looks right. I’m in final pass mode and the more it looks Word the better, now. But I hate having to bend my neck forward as the cursor moves down the screen.

Also, I would like to know how you set the editor width. I tried setting px, but who knows what number that should be. And anyway, nothing happens. I tried putting it in page view and then clicking Use Current, but that didn’t work either, when I went back to the regular editor. I do have pretty background color that I can’t see, though. :slight_smile:

As mentioned, the two features aren’t compatible with each other, I meant that in a technical sense. Typewriter scrolling is achieved by inserting phantom empty lines at the end of the document, and that wouldn’t work well with a fixed page layout view.

You have to set the width of the editor in standard mode and then use that button. Page View is its own thing.

Okay, got it about it about typewriter. It’s a bummer, though… 500 pp of a sore neck!

1345 px is about 8.5 inches if anyone else would like to know… :slight_smile:

Except if you move to a different monitor it doesn’t seem to work any more. Can you change the fixed editor width to inches instead of something as weird and changeable as px? Thx.

Why not just set it to what it needs to be on the other monitor, too? The setting is per computer, not per project, so everything can be tailored to a setup that works best for that particular machine. It’s a bit difficult to use a real world measurement like inches, for this kind of setting. Honestly I never really pay attention to the numbers much, I just drag the editor out to a size that feels comfortable and punch the button. Now that computer is set up forever.