Typewriter Scrolling editor recalibrating with space bar

Suddenly today I am having a problem with the editor mode with typewriter scrolling turned on and Scrivener in full screen mode on a MacBook Pro.

Every single time I hit the space bar, the editor flashes like it is recalibrating its position. Yes, I mean between each and every word. The vertical scroll bar on the right flashes on for that recalibration instant too - that is why it is especially problematic. It makes it look like the screen is jumping - but it really is just that flash of the scroll bar I think.

This is not happening in Composition Mode. Nor in Page View; but of course Typewriter Scrolling does not work in page view. It also does not happen in Editor mode if Scrivener is not in full screen.

I have not changed any settings.

The only change - which was strange - was that when I opened Scrivener today it gave me a message that it needed to - I can’t remember the wording - but essentially register my copy.

I thought that was rather odd since I have owned Scrivener for quite some time and it has been registered the whole time too. I did just purchase Scrapple 4 days ago so I thought maybe that was what caused it.

Then after I clicked okay on the registering message, Scrivener opened to the Project Template Window instead of opening to my document I have been working on almost daily (and which was open when I closed the program last).

The things I have tried are Shutting down and Reopening Scrivener and Rebooting the whole computer.

Okay, a few things I can think of that may help:

  1. Make sure Scrivener is up to date. A number of display bugs have been fixed over time, and this sounds reminiscent of some that I haven’t seen in a while. Additionally the fact that registration kicked in after installing Scapple means you were using an older version of the registration toolkit both use. Scapple installed a new one, and that refreshed Scrivener too.
  2. Secondly, and if you are up to date or that didn’t fix it, what zoom setting do you have your editor set to? Rounding errors with zoom is a common culprit in weird display issues. If it isn’t 100%, try setting it to an even number and see if it goes away.
  3. Losing track of your project: that can happen sometimes. The file that stores this stuff is volatile, and sometimes seemingly unrelated things can cause it to get lost. Just open the project directly from the disk and it should pick up track of it again.

You mention the scroll bar “flashes”, does that mean you have the OS set to hide it if you aren’t using it? Also let me know if you have any Editor preference tab settings that impact full screen. Specifically on the right-hand side in the upper half, in regards to fixed width editor. Let me know what your settings are for those related options.

Two more contextual questions, what version of OS X are you using, and is the MacBook Pro a Retina model?