Typewriter Scrolling -- grayed out in Editor Mode

I am trying to use “typewriter scrolling” while in Editor mode but it is always grayed out and not an option for me to use. It works fine in Composition mode. I’ve searched online and at this forum for a solution but nothing has worked. I’ve checked the “typewriter scrolling line” option under Preferences → Editing but it only works under Composition mode and not in Editor mode. Under “Text Editing”, the option for “typewriter scrolling” is always grayed out. Can someone help? Thanks!

Hello KDWu. Welcome to the forum.

When you’re attempting to activate typewriter scrolling in the Main Editor, have you actually clicked within the Main Editor so that your insertion point is flashing somewhere in the document?

Doing that should then allow the selection of typewriter scrolling in the View > Text Editing options.

If you already have clicked within a document but that isn’t resolving the issue, then you might consider confirming that neither Scrivener nor your Mac have any pending updates. You might also close out Scrivener and reboot your Mac.

If the issue persists after that, I’d suggest opening a help ticket via our contact us page.

Are you in Page View? Typewriter scrolling is not available in that mode.

That was it! I turned on “Hide Page View” under Text Editing and that did the trick. Thank you!!

Thank you for letting me know these options. I did do everything you suggested but it seems I was in “page view” and that was why typewriter scrolling was grayed out. Now that I’ve “Hid page view.” The option is available. Thanks!