Typing Lag?

Hm. I don’t have any image files. I do have a lot of web pages in my research folder, though. Could that be the reason?

I’ve also seen this in another project file and it seemed to go away when I shortened the scenes (I’d pulled whole short stories and left them as one scene). I don’t THINK this should be an issue, but it did go away when I broke the stories down. That project had no images and no web pages.

Anyhow, now it’s happening again, with my novel project, which as I said only has web pages. I do have maybe 20 of them, though… thoughts?

One other thought is that I recently added scrivener links to some scenes (in the inspector) and notes. Could that be it?

I’ve split this from the original thread since that was a tip for people with images in their text, and you incidate that isn’t the condition that is present in your project.

Assuming you are speaking strictly of typing lag, there are other reasons for why this can show up. Excessively large images is just one potential vector. For example we are aware of a conflict with auto-completion and 10.8+ that can cause stuttering when keying in accented characters with the Option key—this only happens with some combinations of letters, and not for everyone.

Another common problem are programs that monitor and perhaps modify your writing area while you type. Third-party spell checkers, text expansion utilities and key loggers are examples of utilities that fall within this class. You can pretty easily check for that kind of stuff by logging out of your account with the Apple menu, then logging back in with the Shift key held down until you are fully logged in. Nothing should be running except for Finder at this point. If the lag persists running only Scrivener and Finder, then third-party utilities probably aren’t the issue.

The last common category is just good old fashioned system load. If a lot of stuff is happening in the background then the whole system can slow down, and this will become more evident in programs that demand a lot from the system. Spotlight indexing and other routine background programs can really hit performance hard since these things not only use up a lot of your computer’s processing bandwidth, but require constant disk activity. These types of things can happen whenever—they are automatically scheduled by OS X, and will be more of a “problem” right after a major update (such as 10.10). To check for this, use Activity Monitor’s CPU and Disk tabs. If the graphs are pegged or you see sustained processes using a lot of CPU, then it’s very likely that will slow down typing. You just have to wait that kind of stuff out, or live with it until it is done.

As to your questions: typing lag should not be impacted in the least by having resources imported into your project. In fact even if you have a massive graphic in one document somewhere, unless you are actually typing in that document there should be no lag. Scrivener is very efficient when it comes to this kind of stuff.

However, one thing it can’t be efficient about is when the web viewer is asked to display a complicated web page (that aspect is out of our hands, it’s just the OS X system web viewer). That can spawn Flash and Javascript instances the eat up a lot of time, even after you stop looking at them. So maybe try clicking on a text file so none of the web viewers are open, then restart Scrivener. Avoid looking at any web files while testing, just type a bit and see if typing speed is smooth.

Thx. This sounds like it will take some time and focus to check out. It’s happening in both of my major Scriv projects. I do have calendar running–launch on start. I’ll check for anything else. I think Mac does have an automatic spell checker, which I hate. I’ll do my best to step through these possibilities and thanks for the advice (you don’t mean to tell me that Windows does a better job with multi-threading, do you?? :smiley: )

Hi there, thanks again for all the detailed advice. I went through all of the possibilities and didn’t see anything that might be interfering or causing a lag. But it’s a serious lag. For example I might type a word and half, and no letters at all show up for several seconds after I’ve typed that bunch. Sometimes there’s even a beach ball.

I work offline a bit and have it set to save to dropbox and backup to my hard drive. Could that be it? That it’s not finding an internet connection? I can’t see why it would matter since dropbox is replicated on my hard drive.

I have pinon with the little ~ above the N in the autocomplete list. So I don’t think it’s a matter of special characters. The only possibilities seem to be something to do with a software update (I have OS X 10.9.5) or background programs. I didn’t see anything concerning on the activity monitor, and when I relogged in with the shift key Scriv behaved the same (Calendar launched and Antisocial popped up to ask if I wanted to be offline…do those count?) (It did change my wallpaper back to some old photograph from a year ago, though… WHY???) I hardly ever look at the webpages I have in the research folder.

Any other ideas?

Okay, it sounds like the computer is running clean. Working offline is fine, Dropbox keeps your files synchronised, they are not “online” in that sense. It’s the same speed as accessing data from anywhere on your computer.

So these programs launched themselves even though you were holding down the Shift key all through the log-in process? Dropbox and all of the other stuff wasn’t running? I wonder if it worked right. I’d try again, be careful to hold it down as soon as you press return on your password, and keep it held down until it stops loading. Nothing should be coming up, if it works. If they come up again, they must be loaded into the OS itself, some things need to do that to modify how it works a bit. Reboot, and as soon as you hear the chime, hold down the Shift key. This is just taking the same step from before a bit further, keeping the OS itself as default as possible. Then again log in with the shift key trick to keep Dropbox and all that stuff from running. If that doesn’t work, reboot normally.

The special characters thing probably isn’t it. That particular bug only happens sporadically, and is very minor, more like a stutter than a lag. It can also be completely avoided by switching off auto-complete. You might try doing that, in the Corrections preference pane.

Okay, I tried all this again (sorry for the delays in between responses… I am offline a lot and have so much to do when I do get online). I relaunched with the shift key held down and nothing else popped up at the beginning except the iSmartClock, which is a clock that floats in a corner of your screen even in fullscreen mode. I don’t know why that would come up when all the other on-launch apps did not. I deactivated the clock and the lag seemed better at first but got worse with time.

I looked at the CPU etc and nothing is going on there–I rarely have less than 95% of my CPU available. I also looked at available storage, which was 33GB and deleted a bunch of music and photos to get it to 41 GB. I have a 120 GB drive. (Sometimes in Windows being too close to your max can slow things down, but I don’t think that’s the case here–1/3 of the storage capacity is available! Do Mac drives need to be defragged?)

I don’t think it’s a website either. I haven’t had any research files open in a long time.

I have not noticed this slowdown with any other program, except that one of my Excel spreadsheets takes a long time to load from its alias on the desktop. However, once it’s loaded it runs fine.

So now what? It is now very unpleasant to work in Scrivener. This is true across all projects. :frowning:

Having a full drive can cause a Mac to slow down and eventually halt, too. But as with Windows, the danger zone is much closer to 10% than where you are. Fragmentation isn’t likely a problem either. The Mac automatically defrags as you use it, and it does a pretty good job of it.

One way to know if it is a problem with disk speed is: does the lag only happen after you’ve stopped typing for a bit, or does it happen constantly while you are typing rapidly? If it is more like the latter, then it’s probably not the disk—all of that is happening in memory. If it is the former, you could try adjusting the auto-save timer in Scrivener’s General preference pane, toward the top. Note this is an idle timer, not a strict interval—it’s how long the software waits after you’ve stopped doing anything at all, before it auto-saves. So small adjustments can make a big difference—setting it to 15 seconds could mean the project rarely auto-saves if you work fairly rapidly. But as a test try bumping that up to something really high like a 100 seconds and see if the problem goes away. If it does, I’d experiment within the 2 and 10 second range and see if you can find a timer rate that doesn’t conflict with your natural rest-work cycles.

As for other programs, that depends highly upon the program. You mentioned Excel, which is a good example of a program that cannot be compared with Scrivener. Microsoft uses their own programming for nearly everything, whereas Scrivener depends heavily upon OS X components—for example the text editor in Scrivener is the same as in Mail (to a limited extent) and TextEdit—but as you can imagine MS Word has nothing to do with that. :slight_smile:

So, I don’t see confirmation if you’ve tried a safe boot as opposed to just logging in without background programs running. I mentioned it briefly before, but didn’t really describe the process. Use the Apple menu to “Restart”, and wait for the system startup chime. Immediately after you hear it, hold down Shift until you see the grey loading screen. Then log in with the Shift key held down again, same as before, and now iSmartClock shouldn’t be anywhere. I think that’s worth a check, since you mentioned that disabling the front-end mitigated the problem for a while. I’m curious to see what happens if the “invisible” components of it are the culprit. Those probably do not deactivate even if you shut off the program itself.

Thank you! I’ll work on all this and report back soon.

Huh, I thought I had posted an update. But that’s okay, because I thought it was fixed, but it’s not. I trashed the iSmartClock app entirely even though I loved it, because it did seem to be a culprit. I also turned off all the launch on log in settings. I did try it with a clean boot and it seemed a little better, but the reality is that I’m going to have other applications running even if they don’t launch on start up. Antisocial, for instance. I set the save to 15 seconds.

Anyway, after a few days it started lagging again, even without anything else running except Chrome and iTunes. Sometimes Word. But none of those other start-up apps, like Calendar or Antisocial or f.lux.

I get BOTH things… lags, with beach balls, when I start typing after a pause, and also lags, though less often (but sometimes) with beachballs, when I’m typing fast. It’s hard to see what could be wrong with the memory… Nothing seems to be taking up much processor time, I have 4 Ram and nothing on here other than Scrivener, Office, and the native Apple apps. I AM often playing iTunes and I recall I had a problem with lags occurring while listening to music, but that problem had gone away for quite some time.

Hm. Huh. Now what?

PS, I had only mentioned Excel because it was the only other app where I saw a lag. And that was only on open, and only with one file. I realize it’s a different puppy.

Just a suggestion, Claudia, that may amount to nothing. Since installing Mavericks a year or two ago, I’ve noticed that my Mac Mini’s hunger for RAM has increased markedly; whilst on Mavericks I almost always used more than 4Gb. That was in sharp contrast to the operating systems that went before. I also noticed that MS Word could be particularly demanding. Strangely, though, my Macbook Air, also on Mavericks, with only 4 GB appears not to be similarly afflicted (although to be honest I do tend to run fewer applications on it concurrently). But other Mac users that I know of have also found 4Gb inadequate for Mavericks, in at least some circumstances.

Incidentally, the Mac Mini now uses Yosemite, and its RAM-greediness has increased again. At this moment the computer is using 8.6 GB, although the only major applications I have open are Mail and Safari (I do have some utility programmes launched as well); fortunately, I have 16Gb installed as a result of gearing up to use a Windows emulator.

Perhaps, on 10.9, you need more than 4Gb of RAM, whatever Apple says in its specifications?

Thanks. Will look into this. How do you tell how much RAM is being used? And can a MacBook Air be upgraded with more RAM? I have an 11".

It appears I’m not the only one with this issue, on both Mac and Windows: plus.google.com/118422615148570 … mZgJqX3ySA

This is merely anecdotal, but now that you mention being on a MBA 11" with 10.9: I actually did have issues with that combination myself. It was never to the point where I couldn’t get work done, but typing always felt sluggish to me, and background operations would severely impact typing speed, to the point of halting it entirely when stuff like Spotlight would do its periodic scan. The problem would also come and go, like you describe.

As I type this, I am using 10.10 on the same exact piece of hardware, and typing speed is flawless. That’s not to say 10.10 is flawless, I’d even hesitate considering an upgrade to it given what I just said about how it might fix your problems. It’s pretty buggy, sometimes disastrously so in my experience (just the other day I had it cold crash to the login screen, leaving dozens of documents unsaved and lost). But, again, the lag I experienced with 10.9 is gone, so I don’t know—maybe it’s worth doing a full bootable backup and then upgrading. If it doesn’t solve anything and you run into to many other issues, you can restore the machine back to its current 10.9 configuration.

On RAM, MacBook Air laptops are not upgradeable without special tools and exceptional skill at modifying circuit boards with a soldering gun around densely packed and delicate components (even Apple will not upgrade an MBA). But, that is no matter in my opinion. The computer I just described above has 4GB of RAM, it’s just a stock baseline MBA 11 and I can throw a lot of work at it—certainly a lot more than just Scrivener and iTunes. I had periodic typing lag problems in 10.8 with it, worse problems in 10.9, and no problems in 10.10. That suggests the issue (for me anyway, not necessarily for you) isn’t hardware related but configuration related—and I can’t even be positive it is 10.10 itself that made things better, as I cleaned out years of junk by doing a full disk format and clean re-install for 10.10. It could be that a full format and clean re-install of 10.9 would have the same effect. I never tried that though as it wasn’t ever bad enough to go to that length.

Thanks, once again. Still struggling. I am intimidated by the back up and wipe option, and don’t have the money to pay someone to do it, so we’ll see.