Typing Lag

I know this has been discussed in past threads but I have yet to find a solution for my work flow. I’ve been using Scrivener since version one. I did not upgrade to version two when it came but recently I upgraded to version three on my MacBook Air.

Everyday I write at least a thousand words in a text file in my Scrivener Draft folder that lives in the Binder by default. Previously I never experienced typing lag in version one of Scriverner, which I used on this same macbook air (mid 2013 model) which I refuse to believe is too slow to type simple text. It can still edit HD video without breaking a sweat, what more with processor friendly simple text…

The first help was when I started a new file and set all of Scrivener’s preferences to defaults as my previous document contained over 230 thousand words. This was a bandaid.

When I’m on a continuous writing spree, it could be up to two minutes of lag before all my typed script catches up to my current typing. Even if it’s just a few seconds, which it is commonly at, it deeply disturbs me as I can’t see what I’m typing in front of me.

One solution that is working is installing the app fresh before each writing session in a new directory. This is not intuitive for me but I have been doing it because I love this program THAT much… But I’m reaching the limit of my patience. I’ve been looking at other apps to purchase just for the thousand words (and still do my outlining in Scrivener) but can’t find anything that has Scrivener’s wonderful visual countdown representation AND the notification with the goal has been hit.

What else can I do here? I don’t want to use another app. I love Scrivener. I’ve used it for years and find all other apps inferior but I can’t seem to solve this simple lag problem. I hope it won’t come down to having to buy a new computer just to use version three of Scrivener.

Just to be clear, I’ve already pumped ups the autosave to 59 seconds. I’ve stripped all customization so no special fonts, back images or themes. I’m not autosaving online. I save to my internal SSD hard drive which should be fast enough to handle text.

I wonder if it may be that the OS is not allotting enough RAM to Scrivener but I have no way of knowing or fixing if if that were true.

I would appreciate any tips.

With Gratitude,

I’m not an expert by any means, but what version of MacOS are you running and how much RAM do you have?

Also, do you have any other programs running in the background that might be dragging down the processor?

I’ve never experienced a typing lag of minutes on any machine.


Hi Edber,

Scrivener should be able to easily handle 230k words in one project.

But if you’re keeping 230k words in one document, then a typing lag is not surprising. Scrivener’s designed with the assumption that you’ll break your documents into smaller chunks than that.

For reference, see this related post by Katherine, of L&L Support team: [url]Beta 29 typing lag - #3 by kewms]


Hi Fitch, thanks for the response. I’m running MacOS 10.15.2. I have 4GB of RAM. This still happens when I run just the program without any others in the background.

e :smiley:

Thank you for the response Jim.

Even when I start a new project, after a few entries (let’s call it just a few thousand words) I notice a slowing down after some time. I’ve previously read the thread that you linked to above. I was thankful to see someone how took the time to create the doc of fifty thousand words to test Scrivener’s breaking point. Thank you! :smiley:

e :smiley:

I’ve had two instances of lag time typing. The first was fixed when I upped the auto-save interval, which you’ve already addressed.

The second was probably unique, but just in case -

I purchased my MacBook Pro used. It came to me with a single user i.d. on it. I tried everything that supposedly would change that name and password to something I wanted and never succeeded. I did succeed in changing Scrivener from hopping along, very responsive, which I’d expect with the machine’s specs, to dragging along, although not so much as you describe, but then my project was more like a 30,000 words, no Binder document more than 3,500 words.

So finally I set up my own i.d., and with trepidation - because I didn’t and don’t have a lot of experience with the Mac system and wasn’t sure I had all the admin rights moved to my new i.d. - I deleted the troublesome i.d. I’d messed with. And that fixed it.

Edit: To be clear, it took deleting the original user to fix it, just setting up a new one didn’t do it.

Thank you for this Tribal Rose. I’m in the middle of a project right now and it’s a little risky for me to reinstall my whole system again with a new ID. If I don’t find a solution by the I finish my project I will investigate your solution. For now I guess I’ll be reinstalling the app each time I start getting the delay. The last couple days seemed fine but the delay has just come back so I will be reinstalling again right now.

My first response to “mysterious” problems is usually to run a utility like Onyx (https://www.titanium-software.fr/en/onyx.html) to clear out all caches, repair anything that needs repairing, delete the Spotlight index and so forth. It doesn’t always help, but at least I know that I’ve cleaned out a lot of junk.

Eek. To be clear, I didn’t reinstall anything. I created a new user, myself, made sure I had all permissions (particularly careful about admin), made sure the new i.d. could access everything, and then deleted the i.d. the machine came with.

If you only have one i.d. on the machine that you’ve been using regularly and haven’t messed with lately, I doubt this would be the solution to your problem.

Thank you for this!
e :smiley:

Got it! Thanks Tribal Rose!
e :smiley:

Just a little update on the hunt for a lag free typing experience with Scrivener. My issue may have to do with my operating system/ Scriverner/ laptop model mix(?) The strange answer I’ve found to do the fix is to restart my computer TWICE(!) On the first restart there is still lag. On the second restart, it’s gone. Strange, yes, but at least it works. I know what to do for my future issues. Thank you everyone here for all the kind and helpful tips.
Edber :smiley:

You might find it instructive to keep Activity Monitor running, and keep an eye on what is using up CPU or Memory, or whatever. I use iStat Menus (https://bjango.com/mac/istatmenus/) and note that sometimes the whole computer stops while something gobbles all the processing power (though it doesn’t last for long). External disks often slow things down, and it is not impossible for a Mac to be infected with malware or some kind of rogue application that insists on “phoning home” continually. This is one of the reasons why I monitor what is going on (I also use Little Snitch – (https://obdev.at/products/littlesnitch/index.html). You never know …

The other suggestion I might offer is to shut down/power up rather than simply restarting. (Twice.) Shutting down will physically force memory to zero, which a restart doesn’t do. Sometimes it makes a difference.

This is a bug in Catalina, related to the Mac OS text engine, which is used by most writing software, including Scrivener. After upgrading to Catalina in October, I discovered it-- I’m guessing anybody who types at a fast speed for very long periods of time will, and most folks don’t. After reaching out to Scrivener tech support and starting a conversation with Rebecca and Ioa, I spent days, over several weeks, doing testing on several different computers, running Mojave and Catalina, and on several different kinds of writing software. Final conclusions, cut and pasted from my emails:

" I spent the REST of yesterday testing other Scrivener-like programs. ALL of them experience the same CPU climb, under the same circumstance: steady 60 WPM typing with no breaks. By the time I have typed ~ 700 words, all programs are regularly topping 80% CPU usage, and showing some amount of lag in the cursor. So then I decided to test TextEdit, which I had never actually tested before, and discovered that THE SAME THING HAPPENS IN TEXTEDIT. "

My solution was to downgrade to Mojave, which was a thrash-- three computers, a clean install on each, but the the typing problem is gone. Ioa’s response supported my conclusion: “From what I can tell, sadly, (Catalina) is still a bit of a performance hog. You were I think the first to report it, but since then we’ve had a few forum threads and support tickets on the matter. The symptoms all match your description—fine for a while, but eventually the system slows to a halt after sustained writing.”

I reported the bug to Apple, and there have since been several upgrades to Catalina, but the problem was so bad, and ate up so much of my time, that I have been unwilling to test. I’m worried that not enough people have this bug (not many type 60WPM for twenty minutes at a time…). I came back here today to find out if it had been fixed, but couldn’t find any threads about it except this one, so I assume the answer is no. I’m a little worried that it might never get fixed, like the scissor keyboard, which will be a bummer, eventually, for those of us who type super fast…