Typing Woes

I’ve only had my Mac for about nine months, and I’ve been using Scrivener for most of them. I started noticing about three or four months ago that sometimes, maybe 2-3 times a week, I’ll be typing and no letters will come up, or maybe every third letter will be missed. I thought it was me at first or perhaps a hardware issue with the MBP until I noticed that I only ever remember it happening in Scrivener. Since then I’ve paid particular attention and in the handful of times it’s occurred, it has indeed only ever been in Scrivener.

There’s no rhyme or reason to it. It will happen and be a problem for 15-30 seconds and then go away. It usually (but not always) will then go away for hours or days. I don’t really remember it happening only when I’ve just woken the computer up or something like that; it’s usually after I’ve been working for a while. And it’s not just the ‘a’ key or the Space bar or something consistent like that.

I believe Scrivener uses some underlying text engine that’s part of the OS, but I don’t know what other apps use that, to see if it’s the culprit. I don’t usually use any other Apple software (I don’t use Mail or Safari or Pages), but it’s possible (or even probable) that one of the other Apps I use also uses this subsystem. Regardless, I’ve never seen this behavior elsewhere.

So…any ideas?

I’m hardly a Mac expert, but I think it’s a Mac issue rather than a Scriv one; certainly I’ve noticed this behaviour on my MBA - it’s popped up in my chat client and various other places. It’s irritating, but I usually find pausing typing for a moment and reclicking in the text box fixes the issue - maybe you’ve only had it pop up in Scriv because that’s where (I’m guessing) you do the bulk of your writing?

I’ve been typing non-stop, all day in Sublime, Thunderbird, Firefox and remotely into a VNC client. Hasn’t happened once (though, again, it doesn’t happen every day). I paid special attention over the last 3-4 weeks and it has always been in Scrivener during that time period (and from what I can remember previously, too).

But none of the apps you mention — I’m guessing about Sublime, since I don’t know it — uses the Apple text engine, used by TextEdit, Yojimbo, Bean, Nisus, and a host of other apps including Scrivener. And Pages and Word are no good as test-beds as neither of them use the Apple text engine. So if this is a problem as temporalranger suggests, it wouldn’t crop up in those apps. I’ve never had such a situation … mild typing-lag in the past, almost certainly caused by an extension to the system, though I’ve forgotten what.


I have periodic problems of this nature (again, across the board, not just in Scrivener) on my MacBook Air that is running Snow Leopard. I’m not entirely sure what causes it, but I have to get out of the loop the same way temporalranger describes, but clicking somewhere and then back again. It may have something to do with background programs that handle text directly, along the lines text expansion utilities or dictation software—but like I say I haven’t had any luck in really pinning down the source of the problem.

Something you can try from within Scrivener is increasing the auto-save interval by just a touch. You don’t need to get crazy with it, because this interval is based on how long you pause working. By default if you pause for two seconds the project will autosave. So if your natural working pattern results in your frequently starting to type after pausing for nearly exactly two seconds, you could be hitting that brief moment where the project is locked to changes. Try increasing it to three or four seconds and see if that clears it up. This setting can be found in the General preferences tab.

In the interests of ruling things out/narrowing down the issue, I don’t think it’s dictation/text expansion software, since I’m not running either (and the MBA was new out of the box two weeks ago, so I don’t have any installed and forgotten about - unless they come pre-installed and automatically activated). I’m on Mountain Lion, so if it’s a bug in the text engine it’s one that hasn’t been fixed between versions.

I’ve increased the auto-save to 4 seconds – I’ll see if that helps, thanks.

I also don’t run any text expander or software like that, and am on Mountain Lion. I have an SSD drive, so even if it were an auto-save thing, it should be really quick. Sometimes this goes on for 30-45 seconds, maybe even longer.

Yeah, that’s about what it is like for me as well. Maybe not quite that long, but it’s a solid chunk of time where the system just doesn’t respond, and then it does all in a blur of potentially destructive actions. Undo always fixes the damage, but it’s still a moment of panic. I wonder if it does have to do with the SSD firmware though. I just got a small pause on my MBP (also SSD); mouse wouldn’t even move or anything.

Thankfully, when I hit the issue it does not store up in a buffer and then replay in a blur of potentially destructive actions (love that imagery, BTW); it simply skips 1 or 2 out of every 3 keystrokes. I’ve never noticed any mouse issues, but I use the mouse (track pad in my case) as little as possible. I can’t remember if I’ve tried clicking outside of Scrivener or not as someone previously suggested. I’ll try that next time.