Ubuntu Kernel Upgrade Caused Grey Screen

This wasn’t an unrecoverable error. (Note, I’m testing the bleeding edge Ubuntu, so um…yeah, hiccups are expected.)

Following the kernel upgrade to 3.1-rc10-oneiric, I started Scrivener. My text and screen were both gray, not the usual black on white. (Changing the settings didn’t change the colors.)

I closed the program, went to ~/.home_user_directory/.config/, and deleted the Scrivener folder. When I restarted the program, the default settings were restored.

Unfortunately, the fix seemed rather obvious, so I didn’t think to run a debug. If I run into it again, I will.

(This runs in a virtual machine and doesn’t share any settings with my standard 10.10 environment. Right now, I have zero incentive to update my usual machine.)

Did you go to Tools -> Options and either set to defaults, or go to Manage and load a preference file that you’ve previously saved? That’s worked in the cases I’ve seen so far, but I’m not running a 3.1 kernel.

I tried both options. The defaults acted like they saved, but nothing happened. Same with the preference file.

Scrivener wasn’t the only program that had issues. TextRoom and AbiWord also had a few minor hiccups.