uh-oh...garbled in word

Okay, here are the steps I took…

  1. Exported a story (not compiled, because it’s a story in a binder with many other drafts) to rft in dropbox from latest version of Scrivener running on latest update of Mac os (I guess… it was Lion, and I run all the updates)

  2. Opened in Word on a PC…Win 7, Word 2010. Edited, saved as Word Doc. Went to add a header. It then changed all the fonts even though it said it was still Times New Roman. As soon as I added the page number the whole doc looked like it had words all over itself.

So the Word doc without a header is still saved and fine. But to submit the story I need a header with page numbers. I don’t know how to get this file uncorrupted without having to re-export and painstakingly re-make all the edits in another RTF file–hours of work.

I guess it’s debatable whether this is a Word or a Scriv issue, but I don’t have issues adding headers to regular Word files. Any thoughts?

Fonts can be a little glitchy when going from one operating system to another, so it’s to be expected that you’ll have to reset the look of the document a bit if that matters. This however is a fairly benign problem—usually the document opens with some application or system default font applied to everything.

Of course, if you were compiling you could put those page numbers in from the get go. Having drafts in the binder—even having multiple drafts in the Draft folder itself, doesn’t necessarily mean the compiler is without point. True, it’s main thing is to glue a bunch of documents together into one, but it does a lot of other stuff too, like setting up the page. If you want a super simple way of doing it, just select the thing you want to compile in the Binder, use File/Compile..., switch the preset to “Original”, and click on All Options. In the Contents pane, set the drop-down menu at the top to “Current Selection”. You should instantly see the list shrink down to the one thing you picked. Now click on Page Settings and make sure the “<$p>” page number counter is in the right position and any other header/footer stuff you need is put in or removed from the defaults.

As for this, I’m not sure without a screenshot, exactly what that means—but it kind of sounds like the line spacing for the document got set to something really tiny?

No, the line spacing was at 2.0, and the letters just looked like there were about 4 versions on top of each other, slightly offset left to right. I finally just reopened the file from dropbox on the Mac and put the headings in that way. Even though it was saved in Word 2010 from Windows it opened fine in the Mac version and everything seems to be okay now. No idea why that would be but okkkayyy.

I just hope that it stays stable if an editor wants to do track changes and comments and all that from a Windows version. Because going back and forth between operating systems is of course the reality. Even if I stay consistent, it’s likely that someone at a university literary journal is using Windows. The last time I exported to Word everything went into a table for some reason. I was submitting to a competitive writers’ conference and half the pages were cut off, even after I thought I fixed it.

As for compile, I’ll experiment with that when I have less time pressure. I have been afraid of it because of that checkbox, “include in compile.” I wish that weren’t the default, because I so often forget to uncheck it.

In a short story collection, so many files are cuts, imports from old Word files, material that might go into a linked collection, material that might be included in a standalone story that would be submitted independently to journals, and I really don’t write by scene as I might with a novel. So when I go to send something to Word, I really only want one text file to go. I’m just afraid that I’ve left some of those “include in compile” boxes unchecked and will get some kind of mess.

Thanks for the advice and for the response!

I’m sure it is safe to say that statistically speaking, all Mac Scrivener projects that are exported as RTF/DOCX/etc end up on a Windows machine at one point or another. So the platform problems I speak of are more small-scale benign issues, like fonts, that people just know and expect. Massive problems like you’re describing could not possibly be endemic or this forum would be little other than people freaking out because their file doesn’t work with their publisher/editor/etc.

So as to what is precisely causing the strange result you are seeing with the characters, I don’t know. That’s not a known issue at any rate. If I had to guess I’d say it’s a bad Unicode character or formatting glitch that got pasted into Scrivener at some point (and since you mention that a lot of stuff gets dumped into the project from other programs, that only makes it more likely), and is triggering a bug in Word. Since it sounds like you have a working solution at the moment, perhaps it is best to just leave it at that. Finding those gremlins can be difficult.

As for the table, I don’t know, some templates have a cover sheet that uses a table to lay out the text. Some people don’t notice that and end up writing their story into a table cell. The other common problem is the Internet. A lot of web pages, particularly older ones, use HTML tables to present their layout, and copying and pasting text from a Web page will bring the table over as well—and the same problem from above happens, you end up writing into a table cell. Just know that if you run into a table problem like that, you can easily strip out table code, without removing the text content in the table, by using the Format/Table/Remove Table menu command.

Anyway, back to present tense: does the source file itself have any important formatting in it? By that I mean any italicised foreign-language phrases or maybe centre-aligned quotes. If not, then one way to get around the whole problem would be to export to .txt. That’ll strip out most weirdness as it just exports the “alphabetic” characters (well, more than that, but you get the idea). Naturally that’s no good if you have formatting in the document that needs to be retained, but if you don’t, opening a .txt file in Word is a quick and dirty work-around. Not something I’d typically recommend, but in a rush it’s better than battling with word processor mayhem for hours and hours.

It’s only, I think, a minority of people that intersperse old revisions and notes into their Draft folder. That’s perfectly okay to do, naturally—the program is designed to allow it and has a whole lot of support for working that way—but what I’m saying is, since most people just put manuscript text in the Draft, the opposite default would be very unexpected.

Does this all need to go in the Draft folder though? While as I said above, it’s perfectly fine to put notes and stuff into the Draft, if you’ve got lots of it and in the kind of “stack of papers on a desk” scenario, it seems like it would be a whole lot easier to just put your story documents in the Draft and use the rest of the binder for notes.

Just to be clear, Compile only uses the Draft folder to compile (there is one exception, but it’s quite advanced and way out of the way of normal usage). Anything not in the Draft folder will never be included in output, no matter what the “Include in Compile” checkbox says.

But yes, absolutely, I meant that implied: only start messing with new features when you’re off deadline. :slight_smile: I do think you’ll benefit from using the Compile feature over Export once you look into it a bit, but at a late stage of the project and a deadline looming, that’s no time to experiment.