UI : medium : scroll wheel does not work in fullscreen

I tried it with typewriter scrolling turned on and off, and in either mode the scroll wheel on the mouse does not scroll the text window.

Kind of related.

In full screen view the arrows on the scroll bar don’t appear to be working.

del

The scrollbar will appear when the text doesn’t fill the view in two situations:

  1. If typewriter scrolling is enabled. This is because to facilitate typewriter scrolling, the view has to be enlarged.

  2. If the text is scaled.

This is normal behaviour and there is nothing I can do about it. Scrollers are a bit funky in Cocoa in general. If you find a single app out there whose scrollers work flawlessly in scaled text views, let me know. :slight_smile:

The arrow-buttons/mouse-wheel bug is proving hard to track down. I don’t have a mouse-wheel, so I can’t test that, but hopefully fixing the arrow buttons will fix that too. It is very strange… Everything worked fine in the BlockWriter demo, and full screen in Scrivener doesn’t work much differently to that. It’s taking longer to track down than some of the more annoying bugs… Drat.

I could be totally wrong, but I think that the two-finger scroll gesture that works on the newer Mac laptop trackpads sends the same signal that a scroll wheel does.

Apparently not, because that is the first thing I tried and that works fine. Strange. Hopefully getting to the root of the non-working buttons will help, though.

Incidentally (and probably unrelated), I tested it in the Keywords HUD and the mini-inspector notes field, and both of those work fine.

Thanks, that’s good to know. The buttons work fine in these views, too. Did the mouse-wheel work fine for you in BlockWriter? If so, we can be fairly sure they are the same issue. This is really odd. I checked a very early interface test of Scrivener I put together and the view is there, too. So it is something basic, possibly to do with the full screen window itself… It definitely isn’t the custom scroll bar, as I tested it with a normal one and the problem is still there. I’ll get it in the end…

Oh, the scroll-wheel has always worked in BlockWriter, for me, so that is not it. It almost is acting as if the text window does not have mouse focus. It could be that the keyboard and mouse are tracked separately. I know that scrolling is definitely handled separately from main focus. If you have the mouse outside of the area in which you wish to scroll, it will not work until the mouse is over it again. Perhaps there is some condition that is not letting that buffer see the mouse position?

Speaking of BW, did you nix the paper texture idea for now?

For the foreseeable future, yes. (Thanks to those who sent paper textures, though!) One reason being that although I liked your idea for “typewriter bleed” with the shadow on the text, I suddenly realised that this can’t actually be done in Scrivener. You can turn text green or any colour you want temporarily, because the Cocoa text system has a “temporary attributes” feature. However, this feature is limited to colours only; shadows can’t be done on a temporary basis. That along with some other minor issues meant that I decided to abandon it for now and go for a simpler approach.

Thanks for the info about the scrolling.

del

That’s why it’s optional. :slight_smile: Personally, I really like it, but I knew that it wouldn’t be to everyone’s taste.

VERY weird. Well, I fixed this one. After hours of cutting out code, checking it, putting it back in etc, just trying to isolate this thing, as a last resort i eventually just went to the .nib file (the file containing the actual interface part), deleted the text view and created it again in exactly the same way - and now the scroll buttons (and hopefully mouse wheel) work fine. It seems that the .nib file somehow got corrupted. So… Fingers crossed, this is hopefully fixed for the next beta.

Who says working well past midnight is unproductive, hey?

Confirmed fixed in Sb2.

Yeeeeeeeeeeeeeeeees!

I noticed that the scroll wheel didn’t work in full screen mode, too. I was using a Logitech mouse. But when I plugged in the mouse that came with my iMac the scroll wheel worked! Very strange. My Logitech scroll wheel works in all Apps except Scrivener full screen mode.

Hope this helps!

Oh no.

Could you please confirm for me which beta you are using? Is it definitely beta 2? (Go to Scrivener > About Scrivner… and look at the information right at the bottom - is it listed as RC b1 or RC b2?)

Please let me know ASAP, as this one is going to worry me.

Thanks,
Keith

Just FYI, I’m using either a MacAlly and sometimes a Microsoft wireless mouse on my G5/10.4.8, and the scroll wheel on either one works just fine in FSM.

FWIW.

Best,

Joey

Thanks… That is a relief… I’m hoping the earlier poster was using beta 1…