UK stage play - character name setting issues

I write lines of dialogue then hit return to type a character’s name and I get this:


Which hasn’t happened when I’ve been writing previously in this project. I must have done something unintentionally in the script settings. I don’t want this blue coloured suggestion of a character’s name.

This is the Auto-Complete function. Look at page 849 in the Scrivener Manual.

I think you’ll find that using auto-complete will speed up your writing. Most screenwriters depend on this feature. I expect playwriting would be much the same.

Thanks. I’ve now read page 849 and it’s enlightening. I’m not so sure I need to use this function. Playwriting is very different from screenwriting. I can’t see if it’s necessary to switch this function off. Or is it a function that has to be turned on if you want to use it?
Sorry if my answers seem naive but being aged and non-technical I find my artistic abilities are being overshadowed by the technical aspects. I do, however, find Scrivener a terrific app and have used it for projects other than playwriting for a number of years.

Give it a try. Whenever you have a scene where two characters are talking to each other, auto-complete spares you from typing their names over and over. Once a writer gets used to it, most find it makes writing a bit easier.

Yes, if it’s on and you don’t want it.

But if I use this function it capitalises the characters names which I don’t want. I don’t mind typing a name each time the character speaks. I’m not in a that much of a hurry to have it done automatically :laughing:

You can turn off auto-complete.

If you want to chage the capitalization, open Script Settings and change the Character Name settings.