Unable to compile kindle file

I’ve used Scrivener for many years and am suddenly unable to compile a kindle document. My Mac and scrivener software are both up to date and I’ve reinstalled the latest KindleGen.

When I try to compile this is the message I get:

Kindle document creation failed
KindleGen failed to generate a .mobi file at the expected location

Please help!

Make sure you have Scrivener 3.1.5.

Then, remove KindleGen, and install Kindle Previewer. Kindle Previewer includes a more current version of KindleGen, which Scrivener will use if available. That should resolve the problem.

Katherine

Brilliant! That’s solved it. Thank you!

Thanks from me as well as I had the same error message.

Thank you, it solved my issue!