unable to compile when degree symbol in title

Dear Scrivener bug hunt team

I noticed that when a title contains the degree symbol, Scrivener will refuse to compile the text file. I click on the compile button, and the application just stands still, with no progress whatsoever. The only way out is to interrupt the compilation.

You can find a test file at this link
dropbox.com/sh/h995lajwzmx6 … a4vwa?dl=0

Thank you so much for your excellent product, and the open format you chose. I like fiddling with the xml file !

with kind regards


That’s odd, I can add a º to titles in one of my own documents and there’s no problem, but when I try to test your sample document, then as you say, it won’t compile.

Unfortunately I can’t see what’s causing the problem – there’s nothing no obvious difference between my settings and yours, but something’s clearly not working. Console is showing the following error:

27/12/2014 11:55:09.524 Scrivener[8403]: *** -[__NSCFString dataUsingEncoding:allowLossyConversion:]: didn't convert all characters

which seems to indicate that there is a bug somewhere but I’m neither a developer, nor connected with Scrivener, so unfortunately I can’t help you any further.

I think your best bet is probably to report this formally to Scrivener by email and include both your test file and the console log.

I downloaded the file from harmonicholas and it wouldn’t compile as it was.

I deleted the degree sign from the name and replaced it with a new degree sign by typing ALT 0.

This compiled the file from harmonicholas without any problems.

Presumably there is an issue with how the original degree sign was typed/entered into the file name.

EDIT: Tried entering a degree sign in the file name using Character Viewer, and this would not compile.

I think the OP just needs to type ALT 0 — that’s ALT ZERO to get the file to compile correctly.

thank you so much for your quick answers.
I sent a mail to the tech support, with a capture of the log file.
with kind regards


This one tripped me up as well. It is worth noting that although Opt-0 (zero) works, it works by using a character that isn’t a degree symbol, but instead is the masculine ordinal indicator (which you’ll probably be most familiar with from the Numero Sign: №). So although it may look right in some fonts, it may not always look right (some will render it with an underscore beneath the ‘o’), and if you need it to be accurate at the Unicode level, you should use Shift-Opt-8 (which will crash the compiler at the moment, but it will be fixed. It’s a silly bug that is many years old, with one of the text engine’s routines that is meant to reduce a string of text to basic ASCII characters—we need that for RTF’s internal bookmarking, which is how table of contents and cross-references function.)

So all around the best solution at the moment is to use another character so that you can compile, but remember to swap it back after you compile, using search and replace.

My mistake. Long made. Apologies.

But I can’t get Shift-Cmd-8 to work.

On my keyboard, I need Shift-Alt-8.

UK / US difference?

Mysterious. Downloaded the OP’s file (again), and this time it does compile with the degree symbol included.

[attachment=0]Test °-2.txt[/attachment]

That was a mistype. I’ve corrected the above.

Okay. As an aside, I wish Apple would standardise Alt/Opt on their keyboards in English-speaking countries. Choose one or the other and then use it universally.

I’ve never understood what their intention was with that, either. They only started putting Alt on the key (in minor print, confusingly almost like a Fn label) to make it easier to figure out which key you should press when using UNIX and MS software on a Mac, but then more recently they mysteriously banished the term “Option” in some regions, entirely. Oh well, I still think it should be an  Key, not a ⌘ key. :mrgreen:

Seems you can’t take the old-skool  out of Io Petr’k :mrgreen:

If anyone searches this thread in the future, here are some tips on using and punctuating the degree symbol…

briarkitesme.com/2015/01/20/how- … ee-symbol/


On PC: Hold down the Alt key, and on the numeric keypad on the right of the keyboard, type 0176 or Alt+ 248

On MAC: Press Option Shift 8.

On iOS: holding the 0 (zero) key.

Source: https://www.degree-symbol.com/