Unable to Compile

This my first post after searching these forums, the manual and watching some videos; also spent more hours reading blogs and so on. Lost a lot of sleep over this. I hope the answer is probably right THERE but I can’t see it.

Here is the issue:

My project (story) is ready for Compile. Click Compile from File menu, use the blue arrow and go through each section all the way through Meta Data, making selections or accepting what is standard. This is for an E-Pub.

Click Compile, a file selector box appears, I click the file (ALL files end with .scriv) Then the file space where selection I made is BLANK. I go up a level and then the project is broken down into several items, I click and the selection bar is still BLANK.

I’ve missed the mark on this, somewhere along the way. After a few weeks of searching and learning, no one I’ve found is talking about this. And so I shame myself publicly for not understanding the basics.

It wouldn’t be so bad, but I have stories finished and back in April I did get to the ebook stage with KindleGen via Compile, but can’t locate that file.

I’ve updated to 1.73 and my projects are accessible, but I cannot compile.

What vital step(s) have I missed?

I’m not sure, but I think the problem here may be that the file selector box you’re seeing is not expecting you to select an existing file to be compiled (which seems to me what you’re doing), but expecting the name of the output file for the project you have currently open.

This file will typically not have the extension .scriv, but the one you’re intending to generate on the output. This file name must be typed by you, or else select an existing previous output file to be overwritten.

You first have to open the project you want to compile, and then Compile will process that project.

Hope this helps!

If I understand what you’re saying, it sounds as if there will be another file with the project as a copy but with a different file extension? Also, because this is the first time I’ve heard “output file” it sounds like that is a step I missed.

I only have all the projects saved with the .scriv extension. This is what automatically is saved by Scrivener. I’m sorry to make this sound so elementary, but that’s where I am with this.

I have the project open and click Compile, all the chapters show up for me to make the selections in the Compile box. When I finish going through the choices in all the left hand headings to set up the ebook and click Compile, the box pops up with the list of .scriv files. I choose the project, and get a blank space where the project file should appear. This is the extent of it, it won’t go through the Compile process because of the blank space for file selection.

Do I have to save each project in a different file extension as well as .scriv? When I choose Save As all I get is All Files, there are no choices for rtf, doc, docx, etc.

I have Libre on my computer, not Word if there is anything connected to this problem. I don’t even use Libre, it’s just there if I ever need it. I tried to Export a project to the desktop and then to send it to Wordpad or Libre to see if I could then save it with the rtf or other extension, but I can’t open it to send it to either software.

Thanks so much r6d2. Did I understand correctly what you said? How do I make an output file with what I have given you in this reply?

You don’t need to select anything on this box. Just type the name you want for the output file on that blank space you see.

For instance, if your novel is named “The cat in the hat”, type “The cat in the hat” (without the quotes) and Compile will generate a file named The cat in the hat.epub.

I was too tired to get what you meant, “This file name must be typed by you, or else select an existing previous output file to be overwritten.” in your first reply.

This worked! Thank you, thank you, thank you! I could kiss you!

Lack of sleep will do strange things to the little gray cells. It was as if I was learning everything new.

I will never forget this kindness.

You’re welcome! Glad to be of help.

Don’t worry. It happens to everybody, I guess. I’ve been around Scrivener for over a year now and I still get sometimes stumped on basic things.

I think it won’t be the last time for me. Something to look forward to :wink: