Unable to compile

I’m unable to compile my Scrivener file.

Note: I’m currently working with Scrivener’s technical support professional but they shared have no more ideas for my situation.

Copying the suggestions suggested by Scrivener Support:

"You don’t create a shared account. It is there already, on your hard drive.

Go to the root of your hard drive, then open the “Users” folder, and you should see a “Shared” folder. Every Mac has this built-in. It exists specifically to allow you to pass material between accounts.

If you don’t know how to navigate to the root of your hard drive, just open “Finder” and click “Go > Computer.” You’ll see a list of drives that are connected to your computer, and you should be able to figure out which one is your primary hard drive. Another way to go directly there is to open Finder and click “Go > Go To Folder” and manually type in “/Users/Shared” (without the quotes). Note that these folder names are case-sensitive."

"For the purposes of this test, you don’t need your license key. The software will run (fully functional) in the new account for 30-days.

Unfortunately, it turns out that just putting the file into the shared folder results in it still having the original user’s file permissions (which is why it is still saying that it is read-only). Try this instead:

  • ZIP the project up first ( CTRL+Click (Right+Click) on it and select “Compress”).

  • Place it into the Shared folder.

  • Log in to the second account.

  • Copy the ZIP file out of the Shared folder, then double-click on it to unzip it.

You should be able to open the unzipped copy."

"Could you try clicking the “Defaults” button to reset all preferences back to their defaults? That way we’ll know if the compile working in your new user account was due to the preferences being reset, or some other factor.

I’ll warn you now, I’ve run out of suggestions. I’ve told you everything that I could possibly think of to try and get to the bottom of this. I simply don’t know what else to try."

I’m not a Scrivener expert but have months of my book project in it and its slowing my progress down considerably.

All those instructions are just about how to move your project from one user account to a new one to test with a clean installation. It tells us nothing about the actual problem you’re having with compile, so there’s no way anyone can give you any advice.

Of course, it’s a long shot anyway, as support are the ultimate experts, but if anyone on here is to have a chance of helping you, you’ll have to explain in detail what the problem is you’re having, preferably with relevant screenshots, and with details of the computer and software versions you’re using.


The large majority of compile hangs result from one of these three factors:

  • There is an unexpected control character somewhere in the book, or a type of formatting pasted in from a word processor that somehow got past import/paste without causing problems, but cannot be understood and modified during compile. Many of the problems in this category have been patched and fixed over the years though, and at this point in time are extremely rare.
  • There is a bad image somewhere in the book—in most cases the image was bad from the very start, and this problem doesn’t become an issue until the compiler has to process it for output.
  • There are simply too many images overall and the compiler is running out of a memory. This may no longer be a problem with Scrivener 3 and its 64-bit foundation, but it is definitely a problem with Scrivener 2 and very large RTF files—we’re talking 250 or larger megabytes in a single document. Very unusual, and nearly always unnecessary (for example a result of pasting massive 20 megapixel camera graphics in or something, and simply changing their display size), but impossible to get around without compiling in smaller chunks or rectifying the initial problem and sizing images to be only as large as they need to be to print at full quality to the intended output device.

For the first two problems, the divide and conquer method is best. Compile half A, and if that works, compile half B, which should crash. Then Compile B1 and if that works B2. Given how mathematics works, by halving halves you can usually get down to the problematic character or image in a few iterations. Once you do, you should be able to omit that document and compile the rest without issues. If that works, the task then becomes cleaning that document.

Worst case: it is very rare that the plain-text (txt) compile method will fail. If all else fails you should be able to get your words out and in one file, and do the final formatting in another program all at once for the final phases of the project. There should be a solution however—so I wouldn’t resign myself to that unless I’d exhausted all other options.

Thank you for your help. I was also working in parallel with Scrivener Support who was running out of ideas as my problem was proving tricky to resolve. Ultimately, I went through the file and pulled out a number of imported images. After that process, I was able to compile sections of my project.

The image sizes and overall project size is not relatively large so am not sure why I specifically was having the issue and perhaps an issue still remains unidentified.

Copying an excerpt of an email from Scrivener’s Support.

“It is strange that an image should turn out to be the culprit, as that didn’t impact things either when we tried compiling it, or when you compiled things in the other account. So it looks like there is still a problem with that specific account on your system, and whatever it is affects the file converter when it is processing images.”

Thank you for your help.

Have you tried running hardware diagnostics? Sporadic crashing during memory intensive processes could indicate a faulty RAM chip, or perhaps some other issue that is normally invisible under normal system load.