Unable to Create or Open a project [ADDRESSED]

When I try to create a new project, it creates the folder for the new project and then the program crashes with an “unhandled win32 exception in Scrivener.exe” error message. When I start up Scrivener again, it tries to open the project it created when it crashed and gives me an error which says the project that was created is incompatible with the current version of Scrivener.

At this point, I cannot get past the create a project screen and can’t use the program.

I am using XP pro on my laptop.

I would move what sounds like the partially created project to the recycle bin and try again with the blank starter template.

I created a new project in the opening sequence without a problem, added chapters too, haven’t tried to import anything yet.

I’ve tried deleting the project that’s corrupt and starting over. The program just crashes again as soon as I try to create a new project, no matter what type I try to create.

I’ve also tried uninstalling and reinstalling the program. No success. I still cannot get past the create a project screen.

I can confirm this, since I’ve gotten the same error.

I clicked on “blank document,” and gave it a file name. When I hit “create,” it crashes. Then when I try to open it up again, I get a popup saying that the file is incompatible with that version of scrivener. Only way I can get the program to start again is to delete everything having to do with scrivener in my registry and try again. For the moment, I’m running it as XP.

I’ve tried deleting the original *.scriv file and restarting (after deleting all scrivener entries from my registry.)

For the record, I’m running slackware 13.1, wine 1.3.4, winetricks enabled.

Going to try running it as Vista and Windows 7 and see what happens…

Edit: it’s not a permissions thing, since the files created have all correct privs.
scriverror.txt (8.28 KB)

Well this obviously is not a permanent solution, but try downloading the zipped .scriv folder I’m uploading to this thread, unzip it, and after Scrivener presents the new project window, use the Open Existing button to open this instead of trying to create a new one.

If that works, keep the zip file around so you can “create” new projects when you need them.

Obviously this isn’t a solution, but until we get the issue sorted out you can at least start with the program. I’m going to have to boot up my XP partition to try and replicate this.
blank_starter.scriv.zip (4.25 KB)

Okay, for the second issue, we haven’t done any trial testing in WINE yet. So there may indeed be all kinds of flaws in that setup.

Right, but it’s the same bug as the other people were having. It’s not a flaw in my setup, since I run all kinds of windows programs without issue.

I downloaded the blank_starter and unzipped it to my computer. I opened Scrivener and tried to open the blank project and Scrivener crashed. When I tried to restart Scrivener, it crashed each time until I deleted the blank_starter project.

Hmm, okay. Yeah going to need to boot up XP to continue this I think.

For what it’s worth, same thing happened to me when I tried to open up the blank document. Again, deleting everything having to do with scrivener in my windows registry and deleting all *.scriv files let me open the program again.

I feel left out watching everyone else play with their new toy and I’m stuck sitting here with a box that won’t open. :frowning:

Okay, finally got XP up and running again. Ran the installer; created a new project; no problems. Blank project was created, I typed some stuff into it, closed it, opened it again. So what SP is everyone on? I’m using SP3.

I’m running Microsoft Windows XP Professional 5.1.2600 Service Pack 3, v.3244 Build 2600

kind of moot for me, but I had to install the MS Virtual C++ 2008 and MS Virtual C++ 6 sp 4 libraries to get it to run.

For what it’s worth, I got the same error with Vista and Windows 7 modes.

I’ve been trying to replicate this crash using a virgin install of Windows XP with service pack 3 and been unable. It all works fine?

Can you confirm which service pack you are running and any special configurations such as WINE or vmware etc?

I’m just running Microsoft Windows XP Professional 5.1.2600 Service Pack 3, v.3244 Build 2600 and don’t have any special configurations that I know of. This computer is a little over 2 years old and has had plenty of things installed and uninstalled over time, so probably not as clean as it once was.

I do have SQL Server 2005, Visual Studio 2005 and the .net framework installed on this computer. Could any of those things be causing a problem?

I’m on build SP3-2600 as well, but my install is extremely vanilla. I’ve only installed a few third-party applications like Chrome. Nothing that operates at a deep level like a virus scanner.

Ok, I pulled out my other laptop which also has Windows XP Professional service pack 3 installed. It’s a pretty clean install and doesn’t have many other programs installed on it since I don’t use it much. After completing the Scrivener install I got this error: “This application failed to start because the application configuration is incorrect. Reinstalling the application may correct this problem” when I tried to open the program.

I uninstalled the program and reinstalled it and got the same error again. Apparently I can’t use Scrivener on either of my laptops.

When I tried opening the program on this laptop again, I decided to let the debugger open when the program crashed during project creation and the error that it’s reporting is a division by zero error. Something must be happening when it creates the new project because all the folders that are created in the new project are empty and there is no .scrivx file.

I do have antivirus programs on both laptops. AVG Professional is installed on the laptop that can’t create new projects and ZoneAlarm Pro on the laptop that can’t install the program correctly at all.