Unable to download latest beta version as connection closes

Hello, I have been trying to download the 64bit Windows beta version. Each time (4 times now); connection closes after 23% of download is done. Download is never completed and connection is closed. I receive the following message: “Connection closed”. I tried to snip the message onto this forum; but that isn’t happening either as it won’t paste the snip. I am attempting to download it on a HP Laptop and had no problem downloading version 13. I will keep trying; but is anyone else not able to download the beta now? Any avenues for help in this. Thanks. :unamused:

Well, I tried again and this time 20% of the download occurred before connection was lost. I may not be able to download version 14 Beta; so I am copying my stuff out of there and putting it into version 1; before it is lost forever. :neutral_face: :frowning: Ho hum.

What you can do is download the installer, uninstall RC13, then install the new one. You don’t need to go through automatic updates–it’s currently bugged for some.

If you are seeing this issue when you’re trying to download the beta from your browser, try a couple of things:

  1. Completely clear your browser cache, close all active windows in your browser and shut it down, then re-open and try again.
  2. Open incognito mode and try it again.
  3. Use a different browser.
  4. Go to a different network – a WiFi hotspot that is on a different ISP than your normal, or put your cell into hotspot mode and use that – and try again.

A broken download like that usually indicates that you are hitting a cache somewhere and not the live object at L&L’s web server. This typically means a problem with either your ISP or an upstream using some sort of transparent web cache or content delivery network to reduce data usage.

Thanks for all the suggestions. I will try them all. I’ll let you know if it doesn’t work; but either way I saved my stuff in a different app so I’m happy about that. Happy New Year everyone. Yeah… :smiley:

The two other suggestions that came to mind for you (and anyone else reading along now or later who sees the same issues) that I have seen this caused by in the past, is malware and misbehaving browser extensions.

I have seen a couple of cases of systems that had malware that were unable to make connections/downloads to random URLs – for whatever reason, the malware either decided something about the connection was off, or trigged the security software in some way. In one very rare instance, the malware was not on the laptop, but was on the WiFi router the laptop was connected to – it had suffered a compromise that caused all sorts of weird side effects. Fixing this one can be difficult, if that’s what it is – often requires a complete reformat and re-install.

The other thing I have seen cause this, if not my original list, is interference from a browser plug-in. This is easy to check for, as you simply temporarily disable all plug-ins to see if the problem goes away. If it does, then you turn them back on one at a time until you figure out which one is causing the issue.

All great suggestions above. Thank you. I tried everything but nothing worked; including the hot spot option on my phone. Yet all is well. This morning I installed the updated beta from scratch and even though I made copies of my documents from Beta 3 previously (because I didn’t want to lose my work), I was surprised to see I could reopen the old documents in Beta 4 so I am good to go and I don’t have to transfer the documents. Thank you again for the suggestions; it could just be my laptop, my server, my whatever that doesn’t allow the updates from the previous version. So today; after installing the new Beta, I am back to writing in the new Beta. Thanks again and happy writing everyone and also Happy New Year. :smiley:

P.S: Can’t wait until the new version comes out for Windows; just like everyone else, I suspect. I do like the changes in what is to come. :smiley:

I’ve been having troubles with connections in Microsoft Windows period. Fortunately, I’ve got a Linux system on my laptop, running Virtual Box with windows on it, and it connects just fine (with FF on Win in Virtual Box). something about Windows TCP/IP stack, I think. At any rate, I switched to Linux and downloaded it from there.

I think if you have a smartphone, you could download it onto a memory card (the Scrivener Beta is only 123 MB), and access that from your PC. I’ve resorted to that method in the past to get around windows occasional poor connectivity issues.

So today, I was able to load the latest version without any issues. Feels awesome to be able to load it up and get to working on my project. Hoping no one else had any issues with loading. I do not know what difference it was from Beta 4 version; but this one came up just fine with the same laptop I used the last time. Yeah. Happy writing everyone. :smiley:

Sorry… moved this question to Mac Forum.

Posting this in the Windows Beta Testing forum is not the best choice, since your concern is Mac-based!

That said, the Mac App store should have the latest 3.2.2 Big Sur compatible version and be offering you the upgrade. I always download direct from Lit&Lat so I can’t see what you see in the Mac App Store.