Unable to enter accented marks by using the Czech keyboard.

Hello.

I am afraid I have found a bug in Scrivener making user being unable to input some accented characters using the Czech or Slovak keyboard.

On Czech keyboard, there is a key which when pressed, nothing it placed in the text field, but the next character entered will become accented. E.g.: ć is written as [accent-key][c-key], ’ as [accent-key][space] and so on. This is okay in almost any Mac OS X application, but not in Scrivener, which doesn’t wait for the next key to be pressed, but interpretes it as an apostrophe instead (the standard english apostrophe is inserted when hitting space right after the accent key), which becomes more funny, when the Czech typography is enabled in Scrivener, because it takes the incorrectly inserted apostrophe then and converts it to a typographic one.

Step by step to reproduce:

  1. Run Scrivener
  2. Switch to the Czech keyboard in Mac OS X
  3. Press the accent key on the keyboard which should not insert anything yet (on the physical Czech MacBook keyboard it is the key adjanced to the left of backspace)
  4. See the apostrophe being inserted (and converted) instead of seeing the yellowish box with an accent mark inside representing the system’s waiting for aditional keystroke for it to compose the right character.

Some technical data:
Mac OS X 10.5.4 on Intel MacBook (mid 2007)
Czech-QWERTY keyboard layout
Czech typography enabled

Have you tried unchecking “Use typographer’s quotes” in the Preferences? This may solve the issue… Let me know.
All the best,
Keith