Unable to get Scrivener working on Intel MacBook Pro

Twice now I’ve downloaded Scrivener (and copied it to my Applications folder) but can’t get it to do anything. When I try to open the Tutorial nothing happens and when I create a new project, I am unable to create a New Text or New Folder using the mouse or key commands.

I’m using an Intel MacBook Pro with Mac OS X 10.4.8.

It looks like a decent program and perhaps what I’m looking for but I’m totally stumped at how to get started. Here’s what I’ve done thus far:

I copied the tutorial to the hard drive and the application to the Applications folder.

I just deleted all support and preference files and tried again. When I open Scrivener I get the window asking about checking for updates and then I get the registration window. I select Try and Scrivener opens. I then use File:Open and select Tutorial.scriv and nothing happens. I still see the Scrivener menus but there are no windows open. There is no error message or beep or anything unusual – I am just returned to Scrivener as if I hadn’t attempted to open anything.

Creating a new project is also buggy. I then select File:New Project. The Assistant window opens. I enter the name “new” and click the Create button. Nothing happens except the create button changes from blue to white – the window stays open. If I click “Cancel” the assistant window goes away and I am back in Scrivener with no windows open. If I click “Create” again I get an error message saying that a file called “new” already exists.

After clicking the Cancel button I use File:Open to open new.scriv. I get a project window open but I am not able to do anything. No matter what menu item or button I click nothing happens (one exception: I can add keywords). I even tried adding files using the little pop-up menu at the bottom left corner and a dialog opened allowing me to select files. I get a warning window and click OK. I then select some jpg files to add and I get a very brief flash of what looks like a progress bar but it comes and goes so fast I can’t really see it. Afterwards, nothing has changed. The project window shows no files or anything else.

I’ve been using this MacBook Pro for about 6 months and I’ve run dozens of programs on it without any problems. Still, on the off chance that there was something wrong I ran Disk Utility this morning and fixed all permissions. I then booted from an Alsoft DiskWarrior CD and rebuilt my internal hard drive. It reported a couple of minor errors and fixed them. Neither task made a difference.

I have an old G4 iMac that I don’t use much but downloaded Scrivener on it and it works great. I’ve tried CopyWrite, Jer’s Novel Writer, Ulysses, Super Notecard and just about every other writing software I can find and – wouldn’t you know it – Scrivener is the one I like the most based on just a few minutes with it on my iMac and it’s the only one that won’t work on my MacBook Pro, which is my primary writing computer.

I’ve emailed Sales and Support and they’re as stumped as I am. Has anybody else had similar a problem with Scrivener?

Erwin Dink

I just created a new user account on the MacBook in case the problem was due to an incompatibility with some other program, preference or configuration. Downloaded successfully and am getting the exact same results. This is clearly an incompatibility with Scrivener and my MacBook.

Here’s my system profile:

Hardware Overview:

  Machine Name: MacBook Pro 15"
  Machine Model: MacBookPro1,1
  Processor Name: Intel Core Duo
  Processor Speed: 2 GHz
  Number Of Processors: 1
  Total Number Of Cores: 2
  L2 Cache (per processor): 2 MB
  Memory: 2 GB
  Bus Speed: 667 MHz
  Boot ROM Version: MBP11.0055.B08
  SMC Version: 1.2f10
  Serial Number: W86224RXVWW
  Sudden Motion Sensor:
      State: Enabled

System Software Overview:

  System Version: Mac OS X 10.4.8 (8L2127)
  Kernel Version: Darwin 8.8.1

Is anyone else able to use Scrivener on a similar system?

Erwin Dink

My boss has been using Scrivener on a 15" Macbook Pro since November, without any problems. I’ll check the stats on his laptop later (he may still be on 10.4.7), but it shouldn’t have anything to do with the hardware.

Very strange behavior you are having. Scrivener is not locking up, but is just ignoring most of your actions? You might try using the process sampler (part of the Activity Monitor ‘Inspect’ feature) to see what Scrivener is doing while it is appearing to do nothing.

Here’s a stab in the dark – are you using any Virtual Desktop software? I’ve found some of the less-polished Mac ones can open new windows in surprising places.

This is very weird. Scrivener itself was developed on an Intel processor with a Mac Book.

Virtual desktops is the first thing I thought of, but that would not explain how a new blank account would exhibit the same problem, nor would it explain the inability for the Create New Project dialogue to dismiss itself.

Some questions:

  1. You say you are able to create keywords, do you mean you can open up the Keyword HUD from the Window menu and type things into the list? When you close Scrivener and reload the Project, do those keywords you entered remain – in other words is it saving what you are doing?

  2. If the Keywords HUD works, what about the project notepad (Cmd-/)? If that opens, does it save information after a restart, too?

  3. What is your file-system formatted as, just regular Mac Extended (with or without journalling?) If you are using something bizarre like UFS, that could maybe cause problems. If you have no idea what I’m talking about here, and you did not get the computer used, then this question can be safely ignored. No Macs ship with UFS.

  4. When you have Scrivener in a state where there is simply no project window showing up, does anything show up in the Window menu? There should be a list of all open projects at the bottom of that menu.

perhaps this is worth a shot…uninstall the app and the pref files, then repair disk permissions and then reboot, download again and reinstall…i’ve done this with a few apps and it fixed the issues…

Done. No change.

I also ran another troubleshooting utility called Applejack. No change.



Keywords are not saved. Here’s something odd… after a fresh install, the first time I opened the Keywords window it listed what looked like categories (the only one I remember was “Characters” but there were two others). I added three new keywords which are remembered while the project remains open but not after I save, close and reopen the project.

Notes are saved between sessions. See foolcrow.com/images/scriv-1.jpg

Mac Extended with Journaling

When I select the Window menu with no projects open all items are greyed out. When I select the Window menu with the Tutorial project open I see an item called “Window” listed at the very end (which corresponds to the visible title in the open window (see above screen shot)).

I just created a new project called “new” and the Window menu also lists simply “Window”.

Also note: I just selected Take a Snapshot of All, heard the sound effect but the Show All Snapshots item is still greyed out.

I just entered a unique word in the Notes and it doesn’t show up when I do a search but it is remembered in the notes when I close and reopen the project.

One more oddity: when I was in the Tutorial project, the font used in the Notes window looks like Verdana plain when in the “new” project it is Bold (and maybe a different typeface but I’m not sure).

I guess my next troubleshooting step is to look at my Fonts folder but I’m pretty sure I haven’t made any changes to the default fonts that were installed when I bought the computer.

Thanks for helping. I’ll hang in for a while with more troubleshooting because this looks like the best writing software I’ve seen.

Erwin Dink


Nope. Not used by me.

Erwin Dink

This is indeed a perplexing one. We had an issue similar to it a while ago, and it did turn out to be a font problem. The user did not have Optima installed, which is the default font. However, safety checks were added in future versions to avoid that problem coming up again. So it could perhaps be a font corruption issue. If you do not use Optima often, it might have gone unnoticed all of this time, not effecting other applications. You say you have run AppleJack, which will reset the caches I believe. Does it reset system caches too? I think so. Either way, given that it did not work, it could be the font itself that is in trouble. Disabling the font in Font Book might be all you need to do; but moving it someplace would be the safest check. You might go through the preferences and change it to another font, too.

The only other thing I can think of is something getting installed into the system level that modified or altered the text presentation system. Something that, in vanilla implementations such as TextEdit, would have no ill effect, but in an application that has extensive modifications made to it, would balk. This would explain why it occurred after the attempted installation to a new account, too. However, that is theoretical. I’ve never heard of an application that does anything like that.

Actually, that might be because words in the project notepad are not looked for when performing a project search. I am not sure of that, but it would not surprise me, since the Notepad has no related Binder item to display in the search results.

That might be because Keith has Verdana (or whatever) set as his default, and you have something else set as the default. The notepad is just an RTF file, I think, and thus subject to font selection choices once initiated.

It was a font problem! I completely forgot that I had disabled some of the default system fonts. I’m a bit of a neat freak and I don’t like having to scroll through typefaces that I never use and so I disabled several fonts. Your comments about fonts made me look there and all I had to do was reinstall the default set and Scrivener is now working fine. I haven’t isolated exactly which missing font was the problem but I will do that next.

If you look at the following picture:


you will see some fonts that are labeled RED. Those are the fonts that had been disabled and apparently at least one of them is required by Scrivener to be installed or it won’t function properly.

One of the first things I do with any new software is configure the preferences to use my preferred fonts (Andale Mono, Georgia, Verdana, Lucida Grande) but apparently that’s not enough. You may want to consider adding a note to the Read Me file that spells out which fonts must be installed in order for Scrivener to function.

Erwin Dink

I’m going to guess that it is either Geneva or Courier which was the culprit. I’m pretty sure Courier is used as the default export and index card font, and while he might have placed some checks for Optima, he probably did not for Courier. As for all of those Asian unicode fonts, you can safely keep them disabled. They are the first thing I dump when I install a new system, too.

The optimum thing to do would be to add Courier (or whichever font is the trouble) to the same list that Optima is on, so that if the user does not have that font on their system, Scrivener should just adapt.

Anyway! Glad you got it working. Welcome to the club and all of that. :wink:

What a lovely thread this was to read. Makes me proud to be a member of this forum. Amber, you’re a pearl!

Tim :smiley: