Unable to open composition window on second screen anymore

One of the little-known but useful features I used to use a lot in Scrivener was the setting to open “composition mode” on a second screen. I still see it in Scrivener 3, under Settings | Behaviors | Composition Mode, but I can’t get it to work anymore.

Rather than a conventional second display, my set-up is to use an iPad Pro (12.9") as my second display, connected via USB-C/lightning cable to my MacBook Pro (orig. touchbar model), running an app called Duet. That’s probably not a common usage scenario of Scrivener, but at least prior to Scrivener 3, I could tick the checkbox on the above setting, choose “second screen”, and it would open full-screen composition mode on my iPad as expected, leaving the usual binder view still up on my laptop so I could work both ways without having to toggle between views.

I have tried various combinations of settings like which screen selected from the drop-down list, which other boxes in that section are or aren’t checked. All OS’s and app versions are updated to latest versions. I can still drag my Scrivener from one display to the other, but my goal, as before, is to have two Scrivener windows open on two separate displays, as I could do before.

Does anyone know if this is a bug, a dropped feature, or just me doing something wrong?

I use Duet from time to time but had never used it i composition mode, so I tested and it worked.

I set it up like below and as you can see it worked just fine.

Thank you very much for the detailed reply, Lunk. It allowed me to try everything set like yours, and while it still didn’t work for me, that suggests the issue is something on my end, not with Scrivener, and that’s helpful.

When I match your settings (making sure Duet is not in mirror mode) and activate full-screen mode, it activates on the laptop and nothing happens on the ipad. However, what it looks like on the laptop is not quite like normal full-screen composistion mode. Instead of the whole screen going into Composition mode (dark background, white text), most of it does but the inspector panel still displays on the right. I can’t grab a screenshot right now but I’ll try to add one later.

I’m able to drag windows back and forth between the displays, so I know that much is working.

I found the solution, or at least, a solution that solved the problem for me. In System Preferences | Mission Control, there’s a checkbox for “Displays have separate Spaces”. Mine was checked. As soon as I unchecked it, Scrivener’s second screen compostion mode worked as expected.

This discovery was serendipitous. I found it while troubleshooting an unrelated issue with wallpapers and thought it could be related when I saw it. I was looking for a way to make a wallpaper change apply to all Spaces at once, and this was the way. So, if you want a different wallpaper for every Space and to use this composition mode option on a second screen, you might be out of luck, but at least you know which checkbox to tick.

Thanks again to Lunk for helping me determine the issue was something in my set-up, not a bug in the app.

Strange… In my setup that box is ticked, but on the other hand, Group windows by application is not. Maybe you should test that. With that setting ticked it could be that all Scrivener windows are grouped in the same space/display?