Unable to open manuscript since Windows 10 update

I’m hoping someone can help with an major issue I have opening an almost complete manuscript.

The steps up to the issue were
29th April - saved virtually complete manuscript in Scrivener, exported whole think as RTF (luckily) and saved a back up
30th April - installed major Windows 10 update, then tried to open manuscript. Scrivener ran, opening a version each time I tried to open the file but not displaying it, and using a high level of my PC’s resources. I reinstalled the software, also tried opening the file on my laptop and neither option worked, I tried using the Windows wizard to run incompatible software (a forum suggestion) and that didn’t work. As I was off on holiday I decided to leave the issue and hope that while I was away a Windows update might correct the issue . Opening backups also failed.
13 May - back from holiday, ran all Windows updates and tried to open the file again - still no luck

I’m using the version of Scrivener that was current on 30 April (it won’t open so I can’t check the version) and using a fast PC that has always coped fine with Scrivener. In a year and half of use I’ve never had an issue, so I’m puzzled by this.

A few notes

  • I save the files on OneDrive for Business but also tried copying files to my desktop to open in case that was causing a conflict
  • when i reinstalled Scrivener I could open the sample file but once I tried to open my manuscript the file failed to open.

Could the file have corrupted and if so is there a way to repair the file? Is there a way to open Scrivener without it opening the last file you worked on, so you can check if the software works?

I could re-import the RTF but I don’t think it would have the sub-folders that my original file had, and it would be labourious to split them up again. I’m also concerned that this issue might arise again.

Any help is hugely welcome. Luckily I’m just about to move into Word (my publisher requires this) so it isn’t as bad as It would have been a few days earlier, but I’d like to tidy up the final version in Scrivener as it is so much easier to manage.

I’ve just uninstalled and re-installed to see if that now works. The freshly installed version won’t open from the desktop shortcut (although I can see in Task Manager that it is running, using 15% of my CPU and very high power usage) but with no files viewable.

I tried the compatibility troubleshooter and running as admin - neither worked.