Unable to prevent insertion of square brackets around comments and in-line annotations when compiling

I am currently using a workflow that involves compiling to mmd and then later to odt/docx using pandoc. With the switch from Scrivener 1.9 to Scrivener 3 (windows) there are a couple of things which don’t seem to behaving the same way which I am looking for help with.

First, a small issue - when I select “compile for multimardown” it only gives me the option to append .md not “.mmd” this is minor, but at the moment I have to manually append .mmd myself which is a bit of a pain. Is there something obvious I am missing?

Second, in order to generate citations, I use citation markers which are later converted using Zotero. No issue there. My problem is that in order to reduce visual, in Scrivener 1, I stored all of these citation markers as comments. Then, when I compiled, I just set it so that comments would be included - this rendered them in-line, as is without anything extra added. In Scrivener 3, I see that you can choose to add proper formatting so that comments will actually be marked as comments, rather than just added text in-line. This is cool, but because of the way I’ve been using it not the desired behaviour - I would like comments to be include but without anything extra surrounding them

When editing the compiling format, I have tried leaving the option for “use formats for comments” blank, as well as leaving the box unticked. Both options leave me with unwanted square brackets. Is there a way to change this behaviour? Is this a bug? It seems to me that leaving it blanks should generate nothing rather than square brackets.

Same with in-line annotations: I was using annotations to visually mark some multimarkdown markup but don’t want them surrounding by square brackets when I compile.

I have tried compiling to plaintext instead, but this doesn’t work for me either, because I would like the option to convert RTF to plaintext so that bold and italics are formatting properly. Help!

Update as I have solved at least one issue and found a work around for another (in case anybody else has the same questions)

  • To render comments in-line without any square brackets type the following under “use format for comments” : <$lnk><$cmt>

  • <$lnk> is the text that is comment is attached to, while the other bit is the comment itself. This is explained when you hover over the question mark, but it took me a while to understand what was being said.

  • For annotations, the best I’ve come up with is input a space. This isn’t ideal, but I can get around it with some post-processing scripts I have. Or might get around to implementing styles to insert markup at a later point. Would still like a way to render annotations as is, without square brackets, like I have with comments.

  • Still unsure why .mmd is not an option when I use dropdown menu, only md - if anybody has any tips here, would appreciate, though this is a minor issue.