Unable to print

This is the first time I’ve tried to print from Scrivener and I’m using v1.11 beta 1 so I don’t know if it’s a bug with the beta version or something else. It’s probably something I’m doing wrong so I’ll put it here in tech support. I’m able to print with Pages '08 Safari and every other Mac program I’ve tried but am unable to print from Scrivener. I’m using a Canon MP610 printer and a MacBook with fully updated Tiger. All I’m trying to do is print one scene but nothing happens.

Any ideas?

When you say nothing happens, what do you mean exactly? A hang? Returns to the main screen? Does anything appear on the console (you should have the console open if you’re running the beta, as requested)?

(Also, please note that posts pertaining to 1.11b should be kept to the beta testing thread, as requested there, otherwise things get very confusing for everybody.)

All the best,

EDIT: I just noticed that I’m calling a Leopard-only method in the printing view, which means it may not work on Tiger. You would get a “selector not recognized” or some such message on the console. This is exactly why you should keep this to the beta testing forum, say what platform you are on, and have the console open when running the beta… Please confirm whether or not you are on Tiger and whether or not you see such a message on the console.

UPDATE: Please re-download. As I surmised, the above was indeed the problem, as another user reported.