Unable to register. Scrivener freezes.

I downloaded the latest version of Scrivener today. When I try to register, Scrivener freezes and I have to force quit the app. Sometimes the splash screen saying eSellerate is being contacted shows up, but not always.

Following the directions in the Scrivener FAQ, I tried updating eSellerate and removing the MindVision folder and reinstalling Scrivener, but the same thing happens: Scrivener freezes up and I have to force quit. I get no error message.

Mac 10.6.8

My usual strategy in these cases is to use Disk Utilities or Onyx (free) to repair permissions and clear out all the old caches just to make sure there are no problems at that level. At least one then knows that there are no problems there. It should also eliminate the possibility of problems with the hard drive.

Martin.

Thanks. Cleared caches, repaired permissions, shut down, started up computer.

Same problem…

Okay, thought I’d try the latest beta, see if that worked:

Current Beta Version: 2.3.5
Build No: 21968

It works, it registered okay, so there’s a problem with 2.3.1