Unchecked documents appear in compile....? 3.3.6 (Mac)

Hi all!

Having a weird issue, which I suspect is my fault, but I can’t figure it out. I have a long history (I thought!) of compiling by selecting Compile/Story and then unchecking any documents that I don’t want to have in my compile. This might include a folder full of backstory documents that I might or might not use. I found this easier than selecting the documents in the binder, since Scrivener remembers my checks and unchecks from session to session.

Just recently (not sure when, since I don’t compile all that often) I realized that the unchecked documents are all appearing in my compiled draft. What am I missing? Isn’t the purpose of unchecking a document to keep it from getting compiled?

Hoping some wise person will help!

:slightly_smiling_face:

Edit: I also just checked the files/folders in my binder, and all the files and folder that I don’t want included in the compile have “include in compile” unchecked.

Hi.

You likely have the filter on.

In the compile panel, to the right, above where you check/uncheck what doc to compile, there is a funnel.
If it is blue, that’s your problem.
Click it, it likely says “all”. Fix that.

image

You don’t want the funnel to be blue afterwards.

1 Like

Oh my gosh!! that completely fixed it! I must have switched the setting at some point without realizing it. Thank you! :pray:

PS thought it might be worth mentioning if folks are reading this that my funnel doesn’t change color, no matter what I tick in the filter settings-- that wouldn’t have made a bit of difference to me, since I had no idea how this operated :upside_down_face:

1 Like

@AmberV
. . . . . . . . . . .
Perhaps some minor bug (?) (Or a mac thing ; I run the Windows version.)

If you are on a Mac, it should be using your system accent colour. For example this is what it would look like when active, using the pink accent system setting (in the Appearance tab):

The only oddity is if you choose the grey system accent colour, but then in that case Scrivener should be falling back to system blue for all such accents like this, for obvious reasons. Could it be you are using an older version of Scrivener? Maybe this was fixed at some point, I don’t recall specifically. Check Scrivener’s version number in the main Scrivener menu, with “About Scrivener”. It should read 3.3.6. (There is no such thing as 3.9.6 as you put in the thread title, on any platform).

The macOS version might matter, too.

Of course if you are on Windows that’s another thing entirely, and themes might make a difference as the theme designer can select what an active button looks like. The stock Dark Mode theme for example sticks with grey, but makes the funnel significantly brighter when it is active. If there is no obvious difference, and it’s a third-party theme, you might want to contact the designer about it.

By the way :
When you check/uncheck documents for compile in the compile panel, that is the setting you are toggling. Whatever you do in the list affects the include/exclude status of your documents in your project. It sticks after you close the compile panel.
If you toggle them back to be included from within the project, they’ll be checked in the compiler’s list next time around. And vice versa.

(In short : most certainly it matched, it is one and only one setting.)

1 Like

Good lord. I have no idea where I got that version number. I did check the version number but obviously didn’t read it. Wishful or scrambled thinking. My version is 3.3.6. And: I see the system accent color now! I was busy staring at the fill color, which didn’t change. Thank you all!

2 Likes