underline color?

When underlining text (with command-U) the underline that appears is red. Is there any way to make it black?

Yes, this just uses the standard macOS system font palette for setting underscore colour.

  1. Select the text you wish to change.
  2. Hit Cmd-T to bring up the Fonts palette.
  3. In the toolbar, click the “T” button (should be second from left) and select the “Color” option.
  4. Pick black!

Note if red underscores are happening repeatedly, make sure you aren’t inadvertently using a Revision Mode colour, from the Format menu.

Thanks a lot!

AmberV - this works, but I have to do it every time I underline something. Is there any way to change the default?
I checked in other word processors, this only happens in Scrivener.
(I’m not using a revision mode - it’s set to “none”)

What I mentioned earlier about their being an underlying setting even if text is not underlined might be the culprit here. If the entire section of text you are using has the red underline formatting applied to it, then removing it in only one or two words as you notice it would not fix the rest of the text.

In my case this happens across all documents and all projects (but only in scrivener, not in other applications). If I go to a different scrivener project and create a new document, start typing, and underline a word, it’s underlined in red. If there’s an overall setting I need to change, do you know where that setting can be accessed?

Perhaps in upper half of the Formatting pane? Since this saves all kinds of formatting for use in the creation of new documents, a mistaken setting made here could proliferate throughout many projects.

Hi Amber V, can you point me in the right direction here, when you say “upper half of formatting pane” I’m not sure what you mean. I have a bar on top of the screen in scrivener that has most typical formatting icons (dropdown font menu, “bold/italic/etc” dropdown, font size dropdown, then icons for bold, italic, underline, then paragraph justification icons, etc) - is this bar what you mean by “Formatting Pane”? If so, I don’t see an “upper half” since it’s just one line of icons (and, I don’t see anything to change the color of underlining in it). If that’s not the formatting pane, then where could I find it?

Sorry for the lack of clarity, the Formatting pane in application Preferences:

Note that the sample text has its own format bar above it. Click the “Aa” button to get to the fonts palette where you can set the underscore colour to black. You should also check the Project/Text Settings… menu in your projects to make sure they don’t have their own specific formatting rules that override these.

Thanks for clarifying. So in the formatting pane, I’ve gone into my “Aa” button and looked at the color of underlining. It’s set to black.
When I create a new document and underline it underlines in black. However in existing documents (in the same project) it continues to underline in red.
I also checked the Project/Text Settings and don’t see any overrides in there.
Any other ideas?
This is driving me nuts… So distracting when typing, looks like a spell check error and stares back at you from the middle of the page, the only red thing on the screen…

Well in that case that’s the formatting in those documents, and you’ll have to use the technique described above to root it out as you come across it. My guess is that that formatting snuck in somehow unaware and got spread around, perhaps through a split up document, or copy and paste, who knows with invisible formatting like that. It does mean you may continue to see new instances in cases where text has been transferred to new documents from ones with the problem, but at least your defaults aren’t spreading it.