Undo delete

Having just selected a (rather large) section of a complex document in the binder and accidentally hit delete instead of return (I intended to start a new section) I was pretty peeved to find I was unable to undo the (accidental) action.

This is serious. Unless I am missing something I have just lost a whole evening’s work.

:frowning:

Take a look in the trash in the binder. They should all be there, so you can drag them back. :smiley: I had the same panic myself a while ago.

Hi,

Whilst undo does not work in the binder (owing to various technical difficulties with Undo in general - you will find exactly the same lack-of-undo behaviour in similar apps such as Ulysses and Copywrite), you have not lost your work. Documents are not deleted from Scrivener until you select “Empty Trash” in the File menu. So your work should be sitting in the Trash folder in the binder.

Note that this is covered in the tutorial that comes with the program, the FAQ in the Tips’n’Tricks forum (linked to in the main page of the Scrivener Help file) and in the Help file itself (Help > Scrivener Help), so you may want to look at these docs to avoid further consternation. :slight_smile: The Help document is fairly comprehensive, and I recommend every user go through the tutorial before delving in with their own projects.

From the Help file (under “binder”):

From the tutorial:

[quote]
The “Trashâ€

Phew: thanks for the speedy resonse!

Whilst undo does not work in the binder (owing to various technical
difficulties with Undo in general - you will find exactly the same
lack of undo behaviour in similar apps such as Ulysses and Copywrite),

mmm. well, I’m not familiar with these. Multiple undo is common enough in other apps… and the delete and return keys are a tad close to one another!

The Help document is farily comprehensive, and I recommend every user > going through the tutorial before delving in with their own projects.

mmm. I have been working with the beta program since before help was available. When I have finished this project I may find time to read them :slight_smile:

Fair enough - I am just proud that I actually finished the Help file after bloomin’ ages, so I like to flaunt it now and again. :slight_smile:

Note that undo gets cleared by the text getting loaded in the document. This changes the state of the undo stack for various reasons. If you lock the document, and move things around in the binder so that nothing gets changed in the editor, undo continues to work. Certainly, Undo isn’t perfect, but you have no idea the amount of work that is required just to get undo working at all for things like this - basically, for everything changed, you have to set up an opposite, and then keep track of all changes, blah blah. Hopefully this will improve in the future, but not for a little while.

Best,
Keith

Most applications of this sort, when you press the delete button, give you a warning dialogue stating that there is no undo available for the action you are about to take. Instead of going about things in the “are you sure?” manner, Scrivener uses the trash can metaphor. So, while multiple level undo might be common in edit areas of applications, in outline trees it is much less common (especially when said outline is linked to files). Generally you only see good multiple-level outline undo in applications which are, no surprise, dedicated outliners such as TAO or OmniOutliner.

Interesting (and thank goodness it does, even if I hadn’t RTFM). In the Finder, however, the delete key does nothing: one has to drag stuff into the Trash explicitly. Perhaps this could be a less heartsinking approach for Scrivener?

True, and this is something that has been brought up as an alternate behaviour in the past (possibly in th form of a preference). I do not recall precisely what the reasoning was for not going with it, but I think it had to do with tampering with the outliner feel of the Binder. While it is not a full outliner, the creation, movement, and deletion of items within it is much more immediate than the Finder. You can make a new document with the key, and promote/demote with Cmd-Ctrl-Arrow keys, disregard folder/file metaphors, and so on.

I am writing my manuscript and inside the binder I deleted the entire chapter. It was an accident. My intentions were to push the return button but I was typing extremely too fast and deleted the entire chapter. I tried looking in the trash folder and it is not there. I tried looking in my saved files to see if i can find the original version but scrievener only brings me the to folder I deleted.

Please tell me there is a way I can retrieve this chapter back…I have over 1,000 words and I wish I could find an “undo” button but I don’t see one.

I even tried looking through my cloud and when I found the file it was the same file that I deleted. The original is not there only the deleted version. I need the original version. Please Please I hope someone can help me, if not all of my work will be lost forever.

P.S. This is what I did…I opened up my project,and inside the binder I had over 1,000 words. I copied then deleted the entire chapter inside the binder THEN I replaced it with another chapter that was already inside the binder. :frowning: I hope that clears it up and someone will be able to help me.

Thank you!

Whenever you close your project a backup is created by default. I would check for recent versions of your project to see if the text of the binder item you are looking for is intact. You’ll find instructions on backup recovery in the user manual, under §5.2.4, Restoring from Backups.

Sure, but there is a checklist for that as the very first step, in the section of the manual that goes over recovery.

There should be an error message saying “Are you sure you want to delete?” It is too easy to accidentally hit the delete button.

For file deletions, the “are you sure” query is not needed because there’s a Trash folder. Just drag the missing file out of the Trash.

For text deletions, are you serious? Do you have any idea how annoying it would be for a writer to have to confirm every single deletion in a complex editing session? So annoying that they’d either turn the feature off, or abandon Scrivener entirely if they couldn’t.

Katherine