Unexpected chapter numbers when using placeholders

It has been fixed indeed. Working just fine now. I have just run a few tests. Big thanks to the whole team :slight_smile:

I have read through all the fixed bugs and I saw “Fixed bug whereby hierarchical numbering may not work properly when mixing <$hn_level> with another numbering type.”

… so I am just wondering: as my architecture is hierarchical, should I normally be using <$hn_level> instead of <$hn> ?

What is the difference between the two?

Thanks for the confirmation, glad to hear it’s working for you!

HN

Simple use of <$hn> at all levels (equivalent to <$hn_level1>):

1.
	1.1
		1.1.1
	1.2
		1.2.1
2.
	2.1

Level_HN

Now say we apply <$L:appendix> to level 1 items, and <$L#appendix>.<$hn_level2> to all descending levels, we would get:

A.
	A.1
		A.1.1
	A.2
		A.2.1
B.
	B.1

So the value of n pushes what is generated by $hn down a literal level, allowing us to use alternate numbering forms at higher levels.

1 Like

@AmberV Thank you very much

I am now thinking: I am going to write an introduction before my first part, so Scrivener is probably going to consider that my introduction is part 1, which is not what I want (well, I would suppose so).

Is there a way to avoid this? I mean inform Scrivener that the intro is not a part… and the conclusion too, by the way.

I was thinking that perhaps I could put the intro in the “front matter”, but I guess that would not be good practice, as the page numbering is going to begin AFTER the front matter.

Scrivener doesn’t consider anything to be a part. Calling it a part is entirely up to you. Try putting the intro outside the folder containing documents with hierarchical numbering, and give it a section type that doesn’t use hierarchical numbering.

1 Like

A simple Section Layout for the introduction that doesn’t having any numbering should be all you need. It’s a simple adjustment:

  1. Open Project ▸ Project Settings..., and add an ‘Intro’ Section Type (or whatever you want to call it).
  2. Back in the binder, right-click on the introduction document, and from the Section Type submenu, select your new type.

That’s all you have to do for now, but later when you set up compile you’ll just assign this to a Layout that doesn’t have any numbering added to its title prefix.

1 Like

Thank you both. I have just created a section type called introconclusion in Project Settings, since both should be treated the same way.

… and I have assigned the two parts this section type in the binder.

When I compile, I will see how to assign them no numbering.