Untitled Document When Compiling iBook

Hi Keith et al,

As you may have noticed on the forum, I’m compiling a lot at the moment and still getting to grips with the numerous configuration options!

I’m having a problem compiling for iBooks. I’m compiling the whole novel but this happens regardless of whether I select the whole Draft container, or just a few chapters. I get an Untitled Document at the beginning of contents list and a blank page at the front of the novel.

I suspect it has something to do with the Separators in the Compile options. I have it set for Folder and Text Separator: Section Break, i.e. a section break before text documents that follow folders.

Now, my first chapter is a file within a folder and I suspect it is putting a section break at the beginning between the first folder and the file within it and creating this Untitled Document.

If I change the Folder and Text Separator to a single line and rely on the section break between folders to split the chapters, I get no content table at all, just a single item called Untitled Document.

Any ideas how I can prevent this?

Thanks so much!
Gilly

Actually, this sounds to me as though you have a stray page break character somewhere in the text itself - the e-book is split up into sections based on where page break falls, which are usually added in the “Separators” section, but if you have one in the text, that can affect it to. So, I recommend switching to page layout view and looking at the documents around where it is happening, looking for a page break in the text.

All the best,
Keith

Hi Keith,

Thanks for responding so quickly – as usual – that sounded hopeful but I’ve checked the first chapter with show invisibles in page layout and there are no erroneous characters.

The Untitled Document falls before the very first chapter. I checked the formatting and there was an erroneous carriage return in the Formatting Level 1+ for the folder which I removed.

Then what happened was the Untitled Document changed to “Chapter 1” which is the name of the first folder holding the first chapter.

I tried setting “Do Not Add Title Prefix or Suffix Documents” to Chapter 1 but this had no effect.

Chapter 1 (the folder) is not included in the compile so I’m not sure why it’s turning up there.

Still at a loss I’m afraid.

Could it be something to do with the fact that I have all of the Title Formatting at the lowest level - the text document itself? The previous formatting levels are completely empty - there isn’t even an extra space.

I’ve included some screen shots which might help shed some light:

  1. The very start which shows no erroneous carriage returns before the first chapter.
  2. Formatting set at document/text level only.
  3. Formatting within the document/text level.
  4. A screen capture of the contents page to follow.

Hope this helps clarify what’s happening.

Thanks so much!
Gilly
Screen Shot 2012-06-13 at 10.15.41.png


This is a screen capture of the iBooks Contents page.

You can see the extra “Chapter 1” top level folder that’s being included despite not being added to the compile.

Have a look at the chapter that follows it – the numbering is out of sequence – One should be The Whaling Wall and Two should be A Middle Easterly. There are also spaces before The Whaling Wall which shouldn’t be there.

Any clues?

Thanks!
Gilly

Hi Gilly,

Could you please zip up and send us the project for looking at?

Thanks!

All the best,
Keith

Hi Keith,

Even zipped I can’t get it on here … I tried PMing you but it’s too big for that too. Do you have a private email I could send it to?

I did a test with a completely blank project and it doesn’t happen. Which means something has got twisted in all my compile testing … and believe me I have been testing a lot to get to grips with it.

I guess I could create a completely new project and copy it all across. I can do that if it will save you time.

The one thing I did notice … in a completely new project there is a compile option for Novel. I don’t have that. I have paperback novel but still have the same issue with that preset.

In the Novel preset in a new document there is the option for a Page Break between folders. I don’t have that, I have Section Break.

Thanks!
Gilly

Hi Keith,

I didn’t want to waste any more time on this - I think it had something to do with me starting from a blank project rather than a template and having only text documents inside which then got changed to folders with subdocuments and on an on my changes went as I learned my way round Scrivener -

So, I opened a new project under the Novel template and copied everything across. It took most of yesterday! But it’s done and fixed. I no longer have the erroneous untitled document.

Would have liked to understand what was causing it … but … there comes a point doesn’t there!!?

I confess this issue beat me! :smiling_imp:

All the best - have a great weekend.
Gilly

Hi Gilly,

Sorry, I forgot to specify that you should send it to our support address, at mac.support AT literatureandlatte DOT com. If you still have the original project, please zip it up and try sending it to that address - at least I should be able to tell you what was the problem, so you can avoid it in future (hopefully).

Regarding the “Novel” preset, that’s exactly the same as the “Standard Manuscript Format” preset. When you create a project from a template (as opposed to from “Blank”), whichever preset is used by default by that template appears at the top of the presets list with the name of the project template. So, the “Novel” template is set up to use the “Standard Manuscript Format” by default, so that appears as “Novel” at the top of the compile format presets. If you set up your own template called “Gilly’s Great Template”, and at the time you created the template the compile presets were set to use, say, “Paperback Novel”, then any projects created from that template would have a compile format preset entitled “Gilly’s Great Template” at the top of the list, which would be identical to “Paperback Novel”. Likewise, if you had set up Compile to use some custom settings which didn’t match any preset, if you created a template from the project, those settings would appear at the top of the list with template name. It just provides a way of quickly returning to the default Compile settings for that project (based on the template from which it was created).

Hope that makes sense!

All the best,
Keith

Hi Keith,

Yes, that makes sense.

I think I tried every compile option known to man! At least the new file is working now.

I do have one slight compile problem left with it though. I want the novel title in the header and then the chapter name on the facing page. I have set these with <$abbr_projecttitle> and <$sectiontitle> in the page setup of the compile.

It works beautifully for PDF.

If I change nothing in the compile but Compile For Word (.doc) it puts the project title on every header and ignores the facing pages setting.

But again, this is a small issue, I’m just being picky!

Thanks for the email address … will send now … wasn’t comfortable uploading my whole book to a public forum anyway :smiley:

Thanks again!

Gilly

Which version of Scrivener are you using? The release version, 2.2, doesn’t support different headers on facing pages in RTF/.doc export. The next version will - you can download a beta here:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

Yes, 2.2.

Brilliant … I’ll download the BETA, thanks!

Hopefully that will be the last you’ll hear of me for a while! This book won’t edit itself after all!!

Have a great weekend Keith.
Gilly