Unwanted Capitalization

Hello! Thank you for creating my favorite writing program ever.

Quick thing - and maybe I’m missing something, in which case, please educate me - the automatic capitalization of letters after periods where there should not be a capital letter is really annoying. For example, when writing “vs.” as in “body vs. mind.” I don’t want the “m” in “mind” capitalized! But it just happens! Another example which comes up a lot for me as I do a lot of quoting and citing page numbers is when, for example, I quote Dr. Laing as saying “Thus, existentially, the concretum is seen as a man’s existence, his being-in-the-world" (p. 27), but that little “p” turns into a big “P,” then I have to interrupt my flow to uncapitalized all these wayward capitals. It’s time consuming and distracting. Any way to teach the software to recognize when not to automatically capitalize a letter after a period? Or, alternatively, is there a way I can set my own rules for auto cap?

Thank you!

  1. The auto-capitalisation feature is provided by the Apple TextKit on which Scrivener and many other third party programs are based, so you need to ask this of Apple—KB has pointed out a number of times that TextKit has not been upgraded for a decade!

  2. Actually, ‘vs’ for ‘versus’ should not have a full stop as the 'S’ is the last letter of the word, just as Mr, Mrs and Ms and many others shouldn’t have a full stop. Or is this an American vs English thing? :wink:


I’ve just tested your quotation example, and as far as I can see it’s working properly (or at least it’s making the correct guess for the majority of cases), depending on the exact punctuation used:

“His being in the world,” (p.26) → comma before " = sentence continues, small ‘p’.
“His being in the world” (p.26) → no punctuation before " = sentence continues, small ‘p’.
“His being in the world!” (p.26) → ! before " = sentence continues, small ‘p’.
“His being in the world?” (p.26) → ? before " = sentence continues, small ‘p’.
“His being in the word.” (P.26) → full stop before " = sentence ends, capital ‘P’.

I suppose the thinking is that for most cases, the capitalisation after the full stop is correct — it’s mainly the specific academic case which requires a lower case p.

Anyway, whether it’s the right decision by the software or not, the quickest way to fix it is to use cmd-z immediately after you’re typed the ‘p’ — this will undo the capitalisation.

Another approach you could take is not to worry about it at the time and do a transformation on compilation for the obvious problem capitalisations — you only have to set this up once.

[attachment=1]Screenshot 2021-03-01 at 10.08.20.png[/attachment]

I’m on Big Sur 11.2.2 and these are the autocorrect settings (Scrivener on the left, System Preferences on the right):

[attachment=0]Screenshot 2021-03-01 at 09.53.19.png[/attachment]

(I know neither of these solutions is perfect, but they’re more likely than Apple changing TextKit :smiley::, so I hope they help a bit.)

I have to say that my strategy with new computers and new applications is to turn off almost every “auto” feature I can find. There is nothing I hate more than a device assuming it knows what I want better than I do. In most cases it is wrong.

On the suggestions of @BROOKTER, I was thinking the OP could use a similar strategy for their suspension points problem. I would set Scrivener to replace three full stops with the suspension points character during editing, and then set up a “… —> stop-stop-stop” (the forum font doesn’t distinguish the two!) replacement in specific compile formats where they need the three full stops—for instance in Manuscript (Courier) for sending to publishers that want that—but not in those formats where they are happy to keep the suspension points.



Edited once.