Unwanted highlighting in new text

I’m still learning Srivener (still on the trial version) and have been experimenting, as one does. Something I did while playing around with the commands led to the situation when new text, under certain circumstances which I haven’t yet been able to pin down, is highlighted. I’ve learned how to delete the highlights, but they still appear the next time I try typing something. This only seems to happen in certain folders/documents.

Another symptom of this is that if previously highlighted text is copied over onto the Inspector synopsis it get highlighted again, and the remove highlight command is greyed out if I try and remove the highlights there.

I’ve evidently changed some meta-setting somewhere, but I can’t figure out where. Can somebody help this struggling newbie?

Hello Gareth,
Try going to the top menu Tools / Options / Editor and make sure you have not ticked the highlight marker on the text graphical display. This is where you set your default text settings for all new documents. That’s why you are getting highlighted text on some new documents but not the older ones. Just select the text in the box and untick the highlight icon on the top right.

Way-hey! An end to unwanted-highlights misery, due to your highly appreciated advice. Many thanks indeed!