update issues

For me the recent update came with two problems.

  1. In my project, all my chapters have a sub title.
    That sub title is right justified. It has been that way since I started the project, long ago.
    This is the first time I have opened the project since the new update and all these sub titles are running off the page.
    The ruler is still in place, it’s setting are still correct. Just the words are running away.
    I have tried selecting that section, select all, and reset - everything. The ruler settings, the page settings, etc. But these words will not move. Period!
  2. The drop down menu on my highlighter no longer works - at all.
    I can right click and change highlighter colors, but right clicking is something I am trying to cut back on as my hand starts ache with too much of it. Lets face it carpel tunnel and other issues like that begin with excessive usage.
    So how can I fix either or both issues?
    Thanks

I’m having a similar issue too with my chapters. I just updated and now centered text is right justified. If I right justify it it goes off the ‘page’. It’s like its not reading my ruler.

Could one of you share a sample project demonstrating the issue? Try creating a new blank project and then dragging one of the problem documents from your project to the binder of the new project to copy it–does the text still act incorrectly? If so, you can zip that project and attach it here on the forum so we can better see what’s going on.

I made a test file for a sample. It’s doing the same thing. Thanks.
TestScriv.zip (48.6 KB)

Thanks for the sample. I see that when you first open the project in 1.7.1, the centred “Test” text shows in the format bar as though it is left-aligned, although the text itself is properly centred in my editor and doesn’t changed when setting the “centred” alignment (whereas it does if you change it to, e.g. justified). So that looks like a minor bug with the alignment settings, but it doesn’t appear to be actually changing the text’s alignment, just glitching in the format bar/menu highlight. (For instance, if you compile the text as-is, “Test” is properly centre aligned, so unaffected by the format bar’s appearance of it being left-aligned.) Incidentally, I see the same thing opening the project in 1.6.1.

I notice though that there’s a right indent set on all the text at 6.5 inches, which you probably don’t want, and that could be causing the problem, although the text should still be wrapping if the editor is narrower than that (and is in my test). I’d try using Documents > Convert > Formatting to Default Text Style on one of the problem documents–try it in your test file, or duplicate one of the documents in your real project to test before you do it on everything–and see if that fixes it. It will apply the default formatting set in the Editor options, so if new documents you create in Scrivener are correct, this may clean up problems left over from imported documents or copied text.

Click and hold on the highlight button to bring up the popover menu with the colours. You can also use the accelerator keys Alt,R,H,M to open the colour dialog for the highlighter.

After I did the convert I reformatted my text from courier back to times new roman and then put the end of my ruler at 6 1/2 where I like it. The text moves in the body, but the top text does not. It’s like my chapter titles don’t want to conform to the ruler end. It’s weird…

And I do want the indents for now. Eventually it’ll get smaller for novel formatting purposes.

EDIT: Scratch that, noting wants to obey the end of ruler at the 6 1/2 point unless it’s left justified.

Ahhh, I see what you’re saying, that the text is centred based off the width of the editor rather than the ruler indent. Sorry, I misunderstood.

Yeah, if I bring the ruler back it’s fine. Or if I expand it. But, the justify wont obey the end of the ruler with right or center justify. It’s odd. Sorry to be so confusing. I had to kinda figure it out myself more too with some tweaking.

@Blade

Thanks Blade you have done an excellent job of exemplifying this issue. I’ve been writing all day and at last check in no one had replied yet.
It does sound like you are having the exact same issue as me. Ironically my ruler is set for 6.5" also. I’m kind of wondering if that’s related. Sucks if it is, since as you seem to know that is what we need for paper back settings.

@MM

Thanks the right click highlight over the drop down does work, but as with right clicking in general, this makes my hand hurt even worse because I have to hold it. :frowning:

Do we know has the drop down menu been discontinued or is this a problem like right justify?

I’ve filed the bug about the alignment problems with right- and centre-alignment, so we’ll try to get that fixed. I do want to bring up the point though that you don’t need–in fact you usually don’t want–to set the right-indent in the editor to achieve the results you want for paperback settings. First, you can override all of this within compile, so the indent can be set there if you require one. Second, you almost never want an indent set for this–you want to change the paper size or the margin size in the compile Page Settings, and leave the text wrapping at the right margin, rather than at a set indent.

As an example, check out the Paperback Novel compile preset–it has a custom page size of 5.08x7.80 inches, with 1-inch margins.

This is changed as part of the popover style of the menu. In case I wasn’t clear, I meant you can click and hold the left mouse button to get the menu as a separate option to right-clicking. You can also use the keyboard with the Alt keystrokes indicated and avoid the mouse entirely.

Thank you very much. I appreciate all your help :slight_smile: