UPDATE: "Untitled Document"

It appears that the most recent update has inserted greyed-out “Untitled Document” labels to empty files and folders. I find this unfortunate as I had been using empty files, and the previously clear visual space around them, as a way of temporarily (visually) isolating groups of files. The new labels just clutters things up in a distressing way.

Besides the visual clues on the file and folder icons - indicating empty files and folders - are entirely self-evident and perfectly adequate.

Is there a way to turn off this feature? Might this be made into a preference, so that I can turn it off?

Thanks.

There is no way to turn that off, however you could use something other than emptiness to help separate things. What I’ve always done, when I need to separate groups of files that shouldn’t be sorted into containers, is to insert an empty item with “————” for the name. I do this often enough to have made a document template for it, and a custom icon.

Yes, that can be done, but it is a long ways from the visual clarity and Zen simplicity of:

Snap 1.pdf (15.8 KB)

And this compared to Scrivener’s most recent version change:

Snap 2.pdf (18.1 KB)

I humbly submit that this new visual change to Scrivener is poor interface design. This is a writing program after all, clutter matters, it makes things less clear and useful. Perhaps I fail to grasp the problem that “Untitled Document” is trying to solve. Once again, I believe it is redundant information, and the existing icons contain all necessary navigational information quite clearly — identifying themselves as file or folder, and indicating whether each contains content.

At the very least, please, please, please make this a preference option.

And I counter that it is quite the opposite of poor design, but preparation for changes to come. It will not be possible to have empty areas in titles in future versions of Scrivener, as changes are coming that will make titling much more flexible for most users. The “Untitled Document” placeholder is to make the current version of Scrivener more compatible with versions to come, so I’m afraid this will not be changing back and it will not be made a preference.

However, if you really want empty spaces, there is an easy solution: just enter a single space character for the title. This will prevent the “Untitled Document” placeholder from appearing, and it will also be future-proof.

All the best,
Keith

As a customer, I agree with mitchpen1. There should be an option to disable this. I have a series of tables that must be on separate pages. Even using a blank space adds an additional title line at the top of the page, which I have to manually delete after a compile to get my tables to fit.

Good UX design (which I teach) is about an intuitive interface that does what you think it should. When I leave a title blank it should be blank. Forcing me to accept “Untitled Document” as a title or to hack in an empty space cannot be the best design decision. It worked better before.

It strikes me that you might be erasing titles for the wrong reason (or making new sections in the first place for an artificial purpose that isn’t to your favour). If your compile settings are such that the documents containing these tables are not actually book sections, then you should be using the Compile As-Is flag in the Inspector so that they do not follow the formatting rules and have a title applied in the first place. Then you can name your table documents pragmatically, rather than according to some remote external constriction, making your search results better, your binder less of a guessing game and your post-compile processing less of a bother[size=80][1][/size]. If you want to talk about UX strategy, that is what the Scrivener outline is all about: liberating you the creative author from the output/programmatic construct—it’s what sets Scrivener apart from stylesheet based outliners such as Word. If you’re having to kludge the outline mechanics to force the compiler to do something, that’s another problem entirely, but in my experience there aren’t too many of those problems left in Scrivener. It’s a pretty robust package for separating what the author needs from what machines and printers need.

Another approach, for when As-Is is not appropriate, is nesting. In some projects I will cut off title generation at a certain level in the Formatting pane. I may export down to “sub-section”, but any documents below what would be that level are effectively invisible to the reader. I can then file components of documents within the visible sections of the book, leaving me with a more useful and granular outline than the official table of contents could ever address.

Finally, and perhaps most to the point, you may consider that if all you need is a page break for the sake of formatting tables that the Edit/Insert/Page Break command is available for just such cases. Why bloat your outline to keep tables from cutting across sheets of paper? Now, if you want each table in its own section so that it can be linked to, referenced from other documents, searched for by keyword or label and so forth—then go for it using one of the other techniques I mentioned. But if all you are doing is paper shuffling, don’t mess up your outline over that.

But if for some reason you absolutely must have a blank chunk of space in your Binder (and everywhere else), Keith already explained a way of doing so.

Notes:[size=80]

  1. Though, if you are really dead-set on this workflow, I would consider leaving some standard title in so that you can do a global search and replace for that generic “REMOVE ME” (or whatever) title, rather than laboriously going through your compiled document and deleting empty lines between tables!

[/size]

Exactly. There is no good reason to have documents without titles in the binder - the entire approach of Scrivener is that the documents have a title and that there aren’t horrible big gaps there. This decision will make more sense in the future with other changes that are to come, but for now it’s enough to note that it will not change, that there are very good reasons for the change, and that if you are using empty titles in the binder then you are probably taking the wrong approach. Not that Scrivener generally tries to dictate the “right” approach in most areas, but it does expect there to be some content in the binder. Again, this will make more sense in the future, but for now, the current version is future-proofed against changes that are to come. Placeholder text has a long and noble history on the Mac and is certainly not contrary to good UX design, even if it is not what a particular user wants.

Well… not wanting to belabor the point, particularly since it is not going to change…

When Scrivener discourages a visual approach of using clean space between some documents it is dictating a “right” approach – limiting a writer’s preferences, and assuming how their brain works best during the squirrelly business of composing works. I find clear visual space between documents in the binder (an outline of ideas) a valuable aid. I find the labeling of this creative preference as a “wrong approach” frankly judgmental, counterproductive, and surprising in a wonderful program like Scrivener which was designed (as I understand it) to give writers flexibility.

This all makes me a little nervous about the coming changes in Scrivener that you keep alluding to. I certainly hope they do not change the current work flow, the visual presentation of the binder, and the binder/editor relationship.

$.02

And I’ve already told you how to achieve just that if it’s really what you want to do (a space for the title).

It is meant as neither judgemental or counterproductive - the upcoming changes will allow for more flexibility, not less, but the payoff is that users who want blank space will just have to enter a space in the title, which I do not think is unreasonable, and it’s easy enough to set up a document template for such documents if you use them a lot. My comment on the “wrong approach” was specifically aimed at the idea of leaving a title blank because you do not want the title to appear in Compile. That is generally the wrong approach. You can still achieve exactly what you want to achieve, and the upcoming changes will make Scrivener more flexible for more users, so I don’t really see that there is any cause for complaint when everything is taken into consideration. But ultimately, whenever there are changes, there will always be some users who don’t like them, and we can’t hope to please everyone, unfortunately.

They do not. For the vast majority of users, they will represent a distinct improvement.

Great, good luck on the revisions. Look forward to taking them for a spin.

The problem with this solution is that every time I close and reopen a project the unwanted “Untitled Document” placeholder reappears, even though I’d replaced it with an empty space. In my usage, this could run up to a hundred empty documents used for visual spacing that are lost. Any chance of changing this behavior (retaining the empty space in these documents)? Please.

Argh. This is a limitation of Apple’s XML classes - if an XML value contains only whitespace, it gets read as blank. That’s annoying. Let me ponder on this.

That makes no sense. Whitespace characters are valid and should be preservable. Bah!

What about string replacing whitespace only values with non-standard characters on save then restoring to whitespace on load? It’s a hack but it might work…

Surely if it’s just a visual requirement, for the ease of separating chunks of documents, then wouldn’t an underscore or two do the trick? Or a pipe? Or any other character?

Once you start inserting Unicode characters into your binder, the possibilities are endless!

that should be in the title, lead sentence of each paragraph and all prefaces of ANYTHING i write.

I hope it’s not too late to tag along with this line of questioning…

I have struggled for two days trying to get rid of ‘untitled document’ and/or fix my compilation issues the only way I could get them to work in the past, and have finally found that there IS no way to get rid of it–

Except, as you say, to put a blank space in.

That causes a problem in my ToC, which is where all my problems arise.

I am assembling ebooks for a novel. My chapters don’t have titles. I either end up with “Chapter One” twice–once in the folder and once in the document, or untitled ‘whatever’ showing up in one or both places, depending on how I attempt to compile.

I have left the document without a title in the past so that Chapter One would be provided by the Folder and not duplicated in the ToC with the document. Now I have part of the ToC single-spaced–things like copyright page and dedication–and the chapters double-spaced.

Please tell me how to compile and have a professional looking ToC since I don’t have titles for the chapters. I’m at my wit’s end.

Thanks.

Inserting a space doesn’t work. Another invisible character does. I tried alt-space (the ‘unbreaking space’ and that works.